• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Radian XL 2.9 no motor beeps

#1
My road worn Radian XL is no longer beeping when I try to fly it. I can bind the controller to the RX but at no time does the motor beep. It struck a blocking dummy late last year and we just got it out over the weekend. The motor would not beep. I used an EDF to see if the Radian motor was faulty but the EDF did not beep either. The only esc I had to test with was a 60 amp with terminals to large to connect with the motor in question. I will look into further testing tonight. Opinions?
 

Merv

Well-known member
#3
I would be suspect of any electronics that sat outside. Especially for that long, more than 6 months.

Test the Rx to see if you can control a servo. Be sure to range check before you fly it.
 
Last edited:

quorneng

Well-known member
#4
The fact that you had no beeps with either motor suggest it is the ESC that has failed. After all it is the ESC that makes the motor beep!
Even with no Rx connected a functioning ESC should make a specific "no signal" beep.
 
#5
Thanks for everyone's input. I tried a smaller ESC and everything worked. Sadly I have to get a replacement before I head out to FFOH19. I had my suspicions the original ESC had failed at least partially.
Thanks
 

quorneng

Well-known member
#6
Captain Video
It might be wise to consider why original failed before simply coupling up the new one.
If operating within their specification ESCs are pretty reliable.
Has your Radian had any modifications to the stock layout?
Has there been any sort of incident that might have caused the motor to overload the ESC?
Is there any possibility of a poor connections and/or an intermittent short circuit?
 
#7
Well....
Late last year a gust of wind blew the Radian XL into a football blocking sled. I chose not to fly it anymore as it need some undisclosed repairs ( don't remember). I fixed what damage was visible to the fuse this spring and finally brought it out over the weekend to find the motor no longer beeped but I could bind the receiver to the TX and control the servos. I took it to my shop and tested the stock 40a esc and found it was not working. I tried another and found it did work. thoughts?
 

quorneng

Well-known member
#8
If it was under power when it hit then it is certainly possible that a stopped prop could certainly cause the ESC to blow. In these circumstances there is a good chance nothing else would be electrically damaged.
Do check the servos for reliable movement. The variable resistance 'pots' in the servos do not like being left static for long periods which can result in 'jerky' movement. Sometimes just exercising full travel on the servo a few times can clear it but it is a danger sign that could lead to 'no movement' with serious consequences if in flight at the time!
 
#9
Well, My son and I took a look at the set up. After removing the shrink wrap from the ESC, we found a little bit of unknown debris on the circuit board. After removing it and then reassembling the Radian power system, it test properly. We will take it out for a test flight tonight. I will report the result tomorrow, time permitting.