• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Spektrum Receiver always goes to bind mode

#1
Hi,
I have a spektrum 4649t receiver (http://spektrumrc.com/Products/Default.aspx?ProdID=SPM4649T) in my new build. When I first powered it up the receiver was automatically in bind mode (rapidly flashing light), this surprised me because it doesn't have an autobind feature like the 4648 receiver, anyways I bound the radio to the receiver and it seemed to work because the light stayed solid. The problem is that every time I power cycled the receiver goes back into bind mode. I initially had soldered the positive wire to to 5v, negative to ground, and signal to the DSM2 SUMD pad on a Betaflight f4.

As for the Betaflight setup I turned on serial rx on uart 3 in the ports tab, in the configuration tab I put "Serial based receiver(Speksat, sbus, sumd) " as the receiver mode and selected spectrum 2048. I also set spectrum on channel mapping.

I checked in the cli that spektrum_sat_bind = 0

Then I found that in an rc groups thread some were saying that you needed to hook up the signal wire to a tx pad of an uart, so I soldered it to tx2, then in Betaflight I turned on serial receiver on uart 2. However this did not resolve my problem: the receiver always goes into bind mode every power cycle.

I also noticed that when I bind the receiver to the radio making the light solid, on the receiver tab none of the channel input bars move when I move the sticks on the radio.

Any Ideas?
 

Attachments

ElectriSean

Eternal Student
Mentor
#2
The signal wire should be connected to a UART Rx pad, not Tx. The DSMX pad is intended for this purpose, but any UART should work. If you followed the binding instructions in the manual (using the bind plug and removing it after, always power on the Tx first) and it still goes into bind mode every time you power it on, it's probably defective. Horizon support is pretty awesome, they will probably send you out a new one right away.
 
#3
Hi, thanks for your reply, I have tried using a bind plug but it doesn't change anything because the receiver is automatically in bind mode every time I connect a battery. I will try a different receiver and see if it works. Horizon support probably is awesome but I live in Italy.
 
#4
Ok, so I switched the receiver and it bound successfully however the inputs in the receiver tab still weren't moving, I found out the the dsm2 tab on the bet flight is uart6 not 3. I switched back to the other receiver and was playing around with the settings in the cli and found that for the spectrum 4649t receiver you need to set spektrum_sat_bind = 1 and set spektrum_sat_bind_autoreset = OFF.