• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Tarot ZYX-M Setup Help

#1
Hello,
I recently purchased a Tarot ZYX-M Flight controller and I hooked it up and i believe all the connections are proper and the led indicator module just blinks green and never goes solid indicating it is ready thus i cannot engage the motors on it. Can anyone lend a hand? Thanks
 
#2
The flashing green light means you have a transmitter error. Either your radio is configured incorrectly or you are triggering a failsafe for some reason.

Hope this helps.

DB
 
#4
I don't know what transmitter you are using, and to be honest I probably know very little about how to configure it. I am sure someone on here knows how to configure it, the other question is, is your receiver plugged in correctly.


If your radio is configured for S-bus plug it into port 7, if it is configured for s-bus2 then port 8. For traditional receivers plug each channel into the corresponding port but that depends on your receiver.

If you tell us what transmitter you have perhaps someone on the forum can be more helpful.

DB
 
#5
I don't know what transmitter you are using, and to be honest I probably know very little about how to configure it. I am sure someone on here knows how to configure it, the other question is, is your receiver plugged in correctly.


If your radio is configured for S-bus plug it into port 7, if it is configured for s-bus2 then port 8. For traditional receivers plug each channel into the corresponding port but that depends on your receiver.

If you tell us what transmitter you have perhaps someone on the forum can be more helpful.

DB
For a reciever I am using a Spektrum AR400 and transmitter is DX6i. So maybe I do have it plugged into the controller incorrectly? I have different cables going from each channel output of the controller into different parts of the receiver, throttle, ail, etc...Is the the wrong way to connect it to this controller?
 
#6
TGY I10

Hello,
I recently purchased a Tarot ZYX-M Flight controller and I hooked it up and i believe all the connections are proper and the led indicator module just blinks green and never goes solid indicating it is ready thus i cannot engage the motors on it. Can anyone lend a hand? Thanks
Hi guys.
I'm stuck, I have TGY I10 trying to hook up to Tarot fc, when connected to the PC I don't see anything changing when I move the sticks, even when I try to callibrate the channels (tarot zyx software). I have tested RX and TX with regular servo and everything is working fine.
I don't know what I'm doing wrong, I just don't seem to be able to connect rx to the flight controller.

Any help much appreciated and Happy Christmas
 
Last edited:
#7
I am using the TGY IA6B reciever with the TGY i6S controller and though my controller says that they are bound the configuration program says that it won't connect.
 
#8
I have the turnigy i10 also. I have got mine bound to rx, everything is good in the software, gps finds all satellites, take off & immediately get a slow red flash from led followed by a fast red flash. Manual says sensor error.....any ideas? Thanks in advance