• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help! Transmitter output issue

#1
Hello!
I've had an Eachine Wizard X220 for a while now and I've loved flying it. Recently, the VTX went out and it crashed. I replaced the VTX and then I realized that an ESC had also blown out. I replaced the ESC. Since I had taken it apart, I had accidentally put the FC/ESC stack on rotated. I fixed the orientation in betaflight because it would be easier than taking it all apart again. However now I have another issue that I don't know how to fix.

All of a sudden, I can't send signals to the drone. I can see that it's connected on my transmitter, but it's not responding to any inputs in betaflight or on the actual drone. I haven't changed any settings that would cause something like this, (at least not that I'm aware of). I just have no idea how to fix it.

Thanks in advance for the help!
-Lucas C
 
#3
Yes, the Tx is showing that it's connected (I named the Rx Wizard on my Transmitter) it's says connected to wizard. I have a Flysky IA6B
 
#5
Sorry for the late replies, I've been pretty busy. The receiver LED is blinking when it's not connected, but as soon as I turn my transmitter on it is a solid red. (Don't worry I don't typically turn my drone on before my transmitter, I just wanted to compare the before and after LED statuses).
 

ElectriSean

Eternal Student
Mentor
#7
First, make sure that the plug on the receiver is fully seated, and the solder joints on the other end of the cable are good. Then check in the Betaflight configuration tab that the receiver type is set to CPPM. If that's all good, you're probably looking at a damaged receiver or FC.
 
#10
Also, I checked all soldered connections and they were all secure. Along with the joints directly from the receiver to the flight controller. Also, I tested the drone with another of the same receiver. It still didn't work, it gave the same error. My only question is how do I select CPPM as an output in beta flight?
 

ElectriSean

Eternal Student
Mentor
#13
Your receiver is IBUS capable, I would try hooking that up before replacing the FC. The power and ground lines remain where they are, but the signal wire will move to one of the UART Rx pads. Move the connection on the Rx to the IBUS port. Then in the ports tab in Betaflight, enable SerialRx on which ever UART you connected to, save and reboot. Then in the configuration tab, set the receiver type to serial and the serial provider to IBUS, save and reboot.
 
#14
Which one do I plug the signal wire into? It looks like there are two iBus ports, one for a sensor and one for a servo. Which pin should I connect it to? And I can just use a jumper for that one pin, right?
 

Attachments

ElectriSean

Eternal Student
Mentor
#15
You want the servo side of the IBUS ports. You can move the whole connector, the + and = on the Rx are all connected.

Is this the original Wizard? If so, it uses an SPF3 clone, so the Rx connects to the IO_1 plug on the FC. To connect to UART3, unplug that cable and plug it in to IO_2 - the identical one on the other side of the FC. Then do the Betaflight config outlined above.
 
#16
Ngl I'm a bit of a noob lol, I'm not sure what all those terms mean in the second part of that. Can you please explain them? Also, I plugged the RX connector into the servo port, am I able to change the receiver type now in beta flight? Or is there something else I have to do first? Thanks for all the help by the way!
 

ElectriSean

Eternal Student
Mentor
#17
Follow the cable that is plugged into the Rx (receiver) . It should go to the FC (flight controller). The FC the original Wizard X220 came with is a clone of the SPF3 - the manual and diagram are here: http://www.seriouslypro.com/files/SPRacingF3-Manual-latest.pdf

The CPPM connection is to the IO_1 plug The diagrams show what all the pins in that plug do, as well as all the other pins and pads on the board. Since we are changing the receiver type, we have to change where it gets connected. IBUS is a serial protocol, so it needs to connect to a serial port on the FC. These are called UART's. UART's have a receive (Rx) and transmit(Tx) pin, one listens for data, one sends data. Since the receiver will be sending data, we want to connect it to an Rx pin. If you look a the diagram for IO_2, you'll see that it is similar to IO_1 (GND, VCC (which is 5v, not obvious)) but instead of PPM it's RXD. Reading to the side you can see that this is UART3. So unplug the cable from IO_1 and plug it into IO_2 and the hardware stuff is done.

On to Betaflight. In the ports tab, enable SerialRx on UART3, then save and reboot. In the configuration tab, set the receiver type to serial and the serial provider to IBUS, then save and reboot. If all is well, you should see some action in the receiver tab. You may need to make changes to your radio settings to enable IBUS, and/or re-bind, I'm not sure. I've never really played with FlySky.

Hope this helps.
 
#19
I just tried that, and it does the same thing. It has an error x% on the transmitter and it says it's connected, but it's not giving any inputs on the receivers tab. However something I noticed is that after I select UART3 and UART3 serial RX and turn them both on and hit save and reboot, It goes back to being off and UART1 one is the only one on. Why is this? And is this normal? (Also, is UART1 supposed to be turned off under the configuration / MSP column) I tried it with UART1 off and UART3 and it's serial RX on, and I also tried it with both UART1 and UART3 + serial RX on and none of the tries worked, they all went back to only having UART1 being the only one active under the configuration/MSP column after I hit save and reboot.
 

ElectriSean

Eternal Student
Mentor
#20
Sounds like a version conflict all of a sudden... What version of firmware and configurator are you running? Near the top of the configurator window there is a log. It may be hidden, but there is a "show log" button underneath the big Connect button. In there you can see the configurator version. To get the firmware version, go to the CLI tab and type version and press enter.

Chances are the firmware is pretty old, and incompatible with the newer configurator.