• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help! Transmitter/Reciever-PROBLEM! Please Help!!!

Try7

New member
#1
Hi everyone.
I'm from Austria.
I ordered one monthe ago from the flitetest shop two DIY-planes (one for me, one for my brother) and the power-pack-F two times .
From Banggood I ordered the FS-i4x tranmitter (also 2 times). The transmitter package includes already a reciever (FS-A6).
Todoy I conected everthing but when I increase the thrust my brushlessmotor isn't spinning. I reconected everything very often, than I changed my Components (because I ordered everything 2 times) . I Changed the reciever, the motor, the transmitter, the esc, EVERYTHING! The motor is not working!
But my servos are working perfectly.
If I connect something its peeping but the Motor won't spinning. I hate it...

What can I do????????
And what's the Problem????
PLEASE HELP!

Thanks. 2c3e9d9b-4e38-45bc-a486-6810bfb54d7b.jpg 842d7005-1c50-4b47-8543-f6f500799924.jpg
 

Paracodespoder

Well-known member
#6
Try this:
-turn the tx (transmitter) on,
-raise the throttle to full up,
-plug the battery in to the esc leads,
-wait for the tones to stop, fully lower the throttle
-wait a few seconds and try raising the throttle a little
Make sure you remove the props when you try this!
While waiting for others to reply, what planes did you get?
 

Try7

New member
#8
But no...
This wasn,t working too.
I think its a probleme between Reciever and motor. Can every reciever use every bruschless motor?
And if I'd buy an other reciever should it fix the problem?
or do I need a new tx? (pls not)
thanks for any reply
 

Paracodespoder

Well-known member
#9
If you have never flown before I suggest a different plane, the alpha and the Charlie can be quite a handful. A tiny trainer on 2s would be ok.
Another thing to try:
-turn on the tx
-Lower the throttle trim to its lowest position (hold trim tab down until beeping stops)
-Plug in the battery to the esc
-Wait for the tones then try raising the throttle

If that doesnt work we’re going to have to call in the transmitter tech people on the forums ;).
 

Hai-Lee

Old and Bold RC PILOT
#10
This may not help but then it can't hurt.

Sometimes I get a really dodgy ESC that will not calibrate properly so I MAKE SURE THAT THERE IS NO PROP FITTED FIRST and then plug the ESC into another channel, (Say 4). I then power up the Tx and the Rx and wiggle the stick from one extreme to the other and do the same with the trims. If that does not work I then reverse the channel and repeat. Normally it will find a setting it arms at and you can then put everything back to normal and do a proper calibration. It has only happened to me about 3 times in the last 4 or so years but it can be very frustrating when it does happen!

Good luck with it!

Have fun!
 
#13
At first...
Thanks It's so great that so many people are helping me to fix my problem.
Second Hai-lee.
I tried that to but its only peeping sometimes.
Here some pics how I connected it.
Maybe it's helpful.
*Edit* I don't know for what I need that white short cable on the esc. Is it necessary?
IMG_20190120_112226.jpg IMG_20190120_112206.jpg IMG_20190120_112212.jpg IMG_20190120_112217.jpg
 

Paracodespoder

Well-known member
#14
You’ve got your esc plugged into the wrong port, that port is the battery port, not the throttle port. Look through the manual to find wich port is for throttle, (probably one).
 

Hai-Lee

Old and Bold RC PILOT
#17
Just to add a little weight to the last three posts.

Ch 1 - primary turn channel - (Normally aileron)
Ch 2 - Elevator
Ch3 - Throttle - (Plug ESC in here)
Ch 4 - Secondary turn channel - (Rudder on 4 ch installation)

BATT port is for use when binding, using a separate UBEC, or for direct battery connection (5V or whatever the rating of the Rx is).

Have fun!
 

CrashRecovery

I'm a care bear...Really?
Mentor
#19
OMG Thanks guys and girls (if there are some), now its working. I read the manuals very often and it doesnt say something "put the throttle in Ch3"

I thank u alot!!!
I bet if you look in the radio instructions it will tell you what channel does what. Anyways easy fix, no go have a blast