Trouble with Gremlin V2 Bundle


Junior Member
So I've assembled my gremlin with the JHEF411 control board that comes with the gremlin 2 bundle. Everything is soldered together and I have run through BetaFlite setup.

Everything works but I'm getting no transmitter signal (Radiomaster T8 lite) in BetaFlite? Not sure what to do at this point.

What I have done.
Checked continuity of all wires - they are good, board powers from battery or usb, FPV camera works and transmits to goggles.
Paired transmitter and R81 receiver, I get chain of PMW waves on sbus wire when checked on oscilloscope. Wired to the 4th buspad on the control board
Updated firmware on Betaflite to STM32F411 (S411) 4.3.2 Nov 28 2022, and updated Impulse RC drivers etc.
Uploaded "Gremlin Guardian Final Dump - T8 Lite" to board.

I can see the orientation of the drone, control the motors within Beta flite, get FPV signal. But the transmitter signal is not showing up in Beta flite. I'm not sure where to go from here? Any help would be greatly appreciated. My son and I are trying to get this together and flying this week while his grandparents are in town.

Thank you,

# dump

# version
# Betaflight / STM32F411 (S411) 4.3.2 Nov 28 2022 / 07:27:10 (60c9521) MSP API: 1.44

# config: YES

# start the command batch
batch start

board_name JHEF411
manufacturer_id JHEF

# name: Gremlin Guardian


Well-known member
In Betaflight, did you set UART2 as SerialRx? I found this diagram, but I'm not sure it's the same one that FT is supplying with the Gremlins:


Junior Member
Yes, I set that and I'm using the sbus pad.

Appreciate the wiring diagram!


  • Ports.PNG
    209.5 KB · Views: 0
  • Receiver.PNG
    389.1 KB · Views: 0
  • Setup.PNG
    250.7 KB · Views: 0


Site Moderator
Site Moderator

Try this and let me know if you still have issues
Hold the bind button down on the receiver and then either plug a battery or plug it into the USB after it gets power release the bind button. The light should now be solid red on the receiver.
Turn the transmitter(T8lite) on
Press the bind button on the transmitter sit it beside the receiver and the receiver light should start to flash red quickly
The transmitter will stop beeping and go solid green.
Power town the transmitter and the gremlin
Power on the transmitter
power up the drone with the usb
Give it a second to link and then you should see everything moving as it should.


New member

has this actually been resolved for Bowtie?

I am running into the same problem with my son. We have assembled everything, but the Radiomaster T8 lite won't connect to the Radiomaster R81 Receiver. We tried everything a hundred times- pressing the bind button on the receiver, plug in the battery, release the button, turn on the transmitter, press bind button (made sure its in D8 but also tried D16). Power everything off and on etc. ect.

The problem is that the red light on the receiver never starts to flash red quickly. Sometimes it stays on solid red but we don't get any signals in bet flight. When we unplug and plug in receiver and transmitter, the red light will be off again.

Also- when executing the Radiomaster T8 Lite Final Dump File ( in CLI, we get plenty of error messages, please see the full log below.

We did have to update Beta Flight to Firmware 4.4.0.

We are stuck at this point and would greatly appreciate some help!

Thanks, Lukas


  • Gremlin Guardian Final Dump - T8 Lite_ ERROR_LOG.txt
    62.9 KB · Views: 0


Site Moderator
Site Moderator

Please reach out to the support desk through the contact us on the store and we can look into your issue.



New member
We have everything done, file loaded and paired with T8. Can’t get one of the motors to reverse with beta flight. Any ideas?


New member
How was this issue fixed?
I have the Guardian Gremlin V2 Starter bundle with what seems to be the same issue, that being the Receiver is not showing in Betaflight (Betaflight Configurator 10.9.0).

1. I have checked my wiring and don't see any shorts or incorrect connections.
2. I have verified loaded the correct dump file (twice).
3. The Receiver shows a solid red led.
4. The Transmitter shows a 4 bar connection.
5. The Flight Controller has a solid red led and a blinking blue led.
6. Under the Setup menu Betaflight is showing the drones orientation correctly.
7. The Motors all work when run in/by Betaflight.
8. The Port appears to be correct.
9. The drone doesn't execute commands when on battery power only.
10. If left idle will play a tune and the camera gets hot to the touch (the plastic lens cover is still on)

I included the corresponding images of Betaflight.
This is my second RC build (The first was a custom foam plane that used a Flitetest power pack) so if there may be something obvious that I missed.


  • Screenshot 2023-09-10 214159.png
    Screenshot 2023-09-10 214159.png
    198.8 KB · Views: 0
  • Screenshot 2023-09-10 214303.png
    Screenshot 2023-09-10 214303.png
    135.9 KB · Views: 0
  • Screenshot 2023-09-10 214320.png
    Screenshot 2023-09-10 214320.png
    259.1 KB · Views: 0
  • Screenshot 2023-09-10 214338.png
    Screenshot 2023-09-10 214338.png
    200.7 KB · Views: 0
  • Screenshot 2023-09-10 215214.png
    Screenshot 2023-09-10 215214.png
    163.2 KB · Views: 0