Help! Aura Board Lite 5 Problems?


New member
Hi! I'm new here but I've been doing the hobby for about a year or so now. I've recently built some FT Mighty Mini planes (specifically the FT Mini Sportster and FT Mini Cruiser) and have been using the Aura Board Lite 5 for both of these builds. It's been a great flight controller so far for all the mini builds that I've done because it makes them less daunting to use in windy conditions.

My problem comes though from doing any editing to the flight profile via the Aura Config Tool, and this has happened twice with two different boards for those two planes, and have caused crashes as a result (and highlighted a glaring safety concern regarding the launch assist mode).

The first time it happened on the Sportster I just made a small adjustment to one of the settings, I forget which, and then did Write All to Aura followed by Disconnect when it was done. What ended up happening was that two of the flight modes were not only erased, but initiating Launch Assist just put the motor on full throttle with absolutely no control authority whatsoever. I had to immediately switch to the only default mode that was working (namely high rates with gyro) and it crashed because it was still close to the ground and I wanted to stop it before it went rogue. I went to fix it via the Aura Config Tool and saw that the first two flight mode settings were completely trashed, and the Channel Source and Channel Out ports were set to Throttle for some reason. I reloaded it from a previous file and it works now.

The second time happened today! I only changed one setting - specifically the Full Throttle Pitch Command Increase under Level Assist Options in the Aura Assist tab from the default 12 to 8 (because I felt like it was pulling up too much on full throttle and I could barely keep it level by pushing the elevators down whenever I wanted to do a fast pass - I figured I would try it to see if that does anything). I even double checked the settings by reconnecting and reading from Aura again to see if it was saved, and it was.
Fast forward to the flight, I take off in what I thought was Level Assist mode (not Launch Assist - I'll get to that in the next paragraph), but it starts... banking and pitching harder than I expected, as if Level Assist was disabled. In fact, that's exactly what it was. In my confusion on why level assist was off, the Mini Cruiser crashed as I tried to bring her back down. As I did the walk of shame towards my plane, I thought back to what happened before and just to be sure, I held the plane by the tail, pointed it away from me, and turned on Launch Assist.

Both motors went on full throttle AGAIN. And worse, it was the same for ALL flight modes, so there was no way of turning it off and keeping it from going rogue had I not kept it down to begin with for testing! I had to gingerly unplug the battery while avoiding the propellers! (Probably should have taken off the propellers first, but I also was not expecting the exact same behavior to happen again either!)

I have pictures attached to show what the settings now look like after plugging it in today. Sure enough, all the Channel Source and Channel Out ports were set to throttle AGAIN.

Is there a reason why this happens and can it be fixed? Otherwise the Aura Board Lite 5 is an amazing flight controller, but this big glaring issue has the possibility of causing someone else who might use Launch Assist to not only lose their planes, but actually have it literally go rogue and crash into something or someone if they try to launch it without realizing that they've lost all control as a result. It's not even immediately apparent because you can do a preflight check of all your controls without realizing that there's a programming error that occurred (they'll move correctly as programmed until you attempt to do Launch Assist, and then all bets are off)!