• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Autonomous Horten BV 38 (Indiana Jones)


Senior Member
I thought it was time I began experimenting with autonomous planes.

I managed to buy a second hand "fixhawk" (pixhawk clone) with GPS and power module for next to nothing, bought a 500mW 433Mhz telemetry radio from hobbyking and spent several days trying to figure it all out. I managed to get the telemetry working, so I can monitor and control the plane through a laptop or tablet. Added a super cheap FPV set and an minim OSD I still had laying around.

Ultimately, this will go in to my Firstar V2, but I thought it would be a good idea to test everything with a frame thats more "expendable" and less likely to cause any damage. I had a Horten BV38 laying around, though it looks cool, I never really liked it how it flies, but as it turns out, it may be a good frame to try this out. I think Im almost ready to fly:

Not the cleanest setup ever, but I wouldnt be surprised if the maiden resulted in a total loss, so Ill clean up once its worth the effort ;).

Among the countless things I learned so far: my servo's hate the 433 radio. Even turned down to 25mW and positioned as far from the servoleads as I can, it still causes them to jitter a bit.

Im still scratching my head getting OSD and telemetry to work simultaneously, if I plug one or the other, it always works. If I connect both, often the OSD will be stuck 'waiting for mavlink heartbeat'. Just rebooting the pixhawk usually solves that, but that doesnt inspire confidence.

Anyway, Ill let you know how it went tomorrow presumably.


Flugzeug Liebhaber
On some OSDs data received before the OSD has booted will lock it up. I power the video system up first before the pixhawk to avoid this. There is a command that will delay this data feed so the OSD can have its cup of coffee before going to work.

Cool plane BTW.



Senior Member
On some OSDs data received before the OSD has booted will lock it up. I power the video system up first before the pixhawk to avoid this. There is a command that will delay this data feed so the OSD can have its cup of coffee before going to work.
Awesome! Ill give that a try.


Winter is coming
I found that installing the latest minimosd extra software from the ardupilot github solved the timing boot issues for me.


Senior Member
Im quite reluctant to update the software on the minim. I tried, got garbled fonts, and then couldnt upload the new fonts, even though I desoldered the 5V bridges and applied 12v to the camera side. Took me forever to find the hex that worked with the fonts already on there.

Oh well, I may just buy a newer minimosd as the one I have doesnt support all the pixhawk flight modes either.


Senior Member
Did my (re)maiden yesterday. Not an unqualified success, but she shows promise. First launch attempt (manual mode):

Yes, you may laugh :). She's nose heavy and even with full up elevator, I couldnt "catch it". Repositioned the battery as much as I could and adjusted the controls and tried again with more success. After I verified she flew ok in manual mode, I went ahead with autotuning because the PIDs are stock and in FBW modes she was more than just a bit lethargic. In the middle of the video you can see me doing some autotuning:

Roll rates quickly became normal but pitch remained a problem even after dozens of pitch iterations in autotune. Even in acro mode, I just didnt have enough pitch authority. Doing a loop would be nearly out of the question. When flying level its enough for basic control, but when in a banked turn, I often found myself pulling full elevator and still achieving barely more than level pitch. Granted, the cg is still too much forward, but trying to understand the logs, I see that I am not getting full servo travel and I suspect there might be a problem with the acc level calibration or trims, and Im not sure how to do that properly. What is 'level' on a plane like this?

Also, Im under the impression something is wrong with the elevon mixing, its as if it gives priority to roll and not enough to pitch when demanding both. Any help with this would be appreciated, Ive uploaded the logs here:


I briefly tried loiter and RTH modes. Loiter worked beatifully, RTH was less impressive or I dont understand what its supposed to do when it reaches home. I thought it would loiter over home but it just did some figure 8s and wandered around. Those are "problems" for later.

Finally, my brother just wanted to do some FPV flying, so I handed him the controls and forgot to put her in manual mode, she was still in 'acro' with the too limited pitch authority. As he did a fast, shallow bank descending turn, he got caught by surprise by the lack of pitch control and while flying ~75KmH according to the logs, slammed in to the ground. Id love to post the video, but by then the mobius battery had ran out. A GPS track will have to do:

I thought that would be the end of it, but to our amazement, there was only minor damage. Both wingtips where torn off, but can be glued back in seconds and that was about it. Oh, and one wire from the pixhawk arming button got ripped as the canopy flew off. That might actually be more annoying to fix (I hate these pixhawk connectors!).

BTW, I found the problem with the OSD was actually in the connector on the pixhawk. It had come lose. Did I mention I hate these pixhawk connectors? Tried to fix it, but failed, so I just daisy chained it from the other telemetry port. That worked ok until one of my 2 hobbyking telemetry radio's died, kind of solving the problem of needing 2 ports.
Last edited:


Senior Member
I think I solved at least one part of the problem: there is a parameter called MIXING_GAIN which defaults to 0.5. That means with elevons, both aileron and elevator channels only have half the normal servo range, allowing full deflection only if you use both full aileron and elevator.

So setting this parameter to 1 doubles the servo range on each channel separately, which more than doubles my throws due to the geometry; it probably triples it and may be too much, but 0.7 or so should do the trick.

Im still a bit puzzled by how to level the plane
Last edited:
Wow, what a difference a bit of tweaking can make :). Changing the mixing gain, moved the cg further aft, recalibrated acc and mags, and did some initial rough tweaking of PIDs based on available log data, and the result is certainly there. Only had time for one battery yesterday, and there was no wind at all, but in auto modes, she flew as if on rails and navigated with impressive accuracy. Here are some sinppets:

At the 50 second mark I engage RTH, and then let it loiter a few circles over home. here is that in google earth:

I still need to tweak a few settings relating to speed and throttle in nav mode, but Im so impressed.
Next up: auto take off and waypoint navigation.


Winter is coming
Nice project! Did I read correctly that you're using the old style elevon mixing setup? That's really old, and deprecated. It kind of explains why you were having sluggish/poor response. The new method and recommended setup for elevons with APM is to use the new elevon output method where the APM software will do the elevon mixing for you. You would then have to remove the elevon mixing on your TX and set it up for traditional roll/pitch/yaw setup.

It works really well and my APM equipped FT Blunt Nose Versa wing flies great with it in all the modes and is quite responsive even in the FBW modes.

Ooops! Just re-read your post, yeah... you are using elevon output -- I didn't see the mixing gain part! Nice to hear you got that sorted out.
Last edited:
Since this is now becoming a high tech research plane, I thought the WW2 camo paint was no longer appropriate, and so I gave it a quick paint job (also helps seeing the thing), removed the canopy and gun turret:

An inside look:

Buzzer, 500mW 433 MHz long range telemetry radio and D4R receiver:

The "brain" (HKpilot32 pixhawk clone):

GPS and external compass, happened to fit nicely where the gun turret was:

Pitot tube and (rubbish!) analogue airspeed sensor:

The underside of the canopy is also crammed with electronics:

You see a mobius camera, 5V regulator, LC filter, FPV video transmitter and osd.

It all *BARELY* fits together.

Next step is adding a raspberry Pi and Pi-noir camera with special filter for NVDI imaging:

Unfortunately my raspberry seems dead, waiting for a new one.

Oh, and yes, that is a bottle cap protecting the mobius lens :)
And my raspberry is ready for its maiden. It looks a bit weird, but I really had no space inside the fuselage anymore :)

The raspberry is connected to the pixhawk for camera triggering. Later I will run a mavlink proxy so it can talk to the pixhawk and do things like geotagging the images.

Currently only one standard camera module is connected:

IM waiting for a board that allows many more camera modules to be connected to a single Pi, so I can do NDVI and multi/hyper spectral imaging at a tiny fraction of the cost of real multispectral camera's. But we'll see how a single camera visual spectrum survey goes first without gimbal and with a tiny lens.
Last edited:
thanks. Wasnt a success though. The rasperri CSI camera cable appears to act like a giant antenna thats interfering badly with the GPS. I tried solving that by shielding the cable with aluminium foil.

And then there is the small problem that Im unable to launch it lol. My throwing technique is bad and with the current wingloading, I need wind and/or a slope, and/or a bungee, and/or a better thrower. I tried a few times, but it just nosed over in to the ground and made me look like a complete moron. Ill try again this week because Im dying to find out if the raspberry photo's are usable or not, but soon Ill be moving to a larger, more suitable platform.


Winter is coming
I have found the mobius is also a source of gps interference. I added copper tape shielding to the inside case of mine, but there is a shielded replacement mobius case that can be purchased.