Beecore Breaks When Motors Plugged In


New member
So today my parts for my first tiny whoop came in, and was super exited to build and fly as soon as possible. I soldered everything up, and everything seemed to work. The board bound with my Tx. However when I went into cleanflight to play around with settings (while waiting for my motors to arrive) it asked me to update the firmware.

This is the first problem. When I try to flash the firmware, it says port could not be opened. The only way to get cleanflight to recognize the board again is to go into settings and tell my computer to forget the board. Then I unplug the board and re-plug it back in, and we are back to square one.

The second problem occurred when my motors arrived. When I plug the motors in, the Beecore flashes like crazy and all the motors twitch. When I plug it into my computer, my computer tells me your usb device has an error, and I cannot connect.

Beecore F3 EVO (DSM2)
Insane motors from tiny whoop
220mAh 1s lipo

If anyone knows anything that could help with either of these problems I would really appreciate it.



New member
Hi, thanks for the quick response. I have tried Betaflight and have the exact same issue. I have looked over the manual (for the Beecore not Beebrain) to no avail.


Construire Voler S'écraser Répéter
I have the older beecore and my motor settings are:

BRUSHED protocol
enable Motor PWM speed separated from PID spped
16000 Motor PWM Frequency
enabled Motor Stop
enabled Disarm motors regardless of throttle value

My PIDS are:
Roll P 80; I 50; D 60
Pitch P 100; I 50; D 60
Yaw P 180; I 45


New member
the problem is that i cant change any settings though. its like there is nothing i can do software wise. so is my board just damaged? or do i need to short some pins or something? i have no clue. thanks for your help anyway though.


New member
It worked!! my Beecore can now successfully connect to cleanflight after a flash.
That also fixed my motors breaking my connection issue.

Thanks sooooooo much!


New member
I have similar problem with the motor.
When I connected all the motors and plug the battery one of the motors (m4) start spinning.
I bound TX and RX, set up everything with instructions in cleanflight. On computer is everything fine, but after I plug battery one motor starts and that's it. No reaction on the sticks, arming etc.
I have no idea it's beecore broken or I was made some mistake.

Beecore f3 evo
Flysky FS-i6S


New member
That's my settings :)



  • 1582680527888.png
    233.5 KB · Views: 0
Last edited:


New member
I hope that you find my mistake.
I fight with this three days.
Connecting, disconnecting, setup, repeat...
Always it's the same effect, motor4 still spinning after connect battery.


New member
Thanks for You help.
I think but problem is not in software, it's something different.
I was trying this swich earlier, but it's not solve this problem.
I tried to flash this board, but after that the motor spinning.
I'm think it's taking the power from other source, like from led or something.
When I chekied the motors in Cean Flight, motor no4 rotate during the test on lowest position (three other motors are stoped) and when the throttle was changed to a higher level, the all four motors accelerated (with the fourth motor).
I think it's mechanical/electronic problem - something in the orginal soldering of the board, or some of the elements is broken...
I think I will spend a lot of time finding a solution to this puzzle with the magnifiing glass...
Thnks again, and if I'll find the solve of this thing, I'll write. :)


Eternal Student
Personally, I would ditch Cleanflight all together and go with a slightly older Betaflight like 3.5.whatever is latest.
  • Like
Reactions: FDS


New member
BetaFlight flash doesn't help to.
Maybe it's ESC broken.
I tested motor from motor control from BF and dont change rpm, when bars was moved up & down. :(
I maybe I have to make a tricopter from this board :p