Help! Betaflight will flash board but won't connect


New member
I bought a new Omnibus F4 V5 board but I can't get it to connect to Betaflight. I keep getting Serial port errors which is strange because if I try to flash the board I can do that. I tried using both Zadig and ImpulseRC to fix the serial port error but all I can get is the DFU connetion to flash the board. I tried flashing it with a new firmware, still cannot connect to the Betaflight configurator (serial port error). Used a different USB cable/port, reset the computer, reinstalled Betaflight, no dice.

Windows 10
Betaflight 10.4.0
LHI Omnibus FPV AIO F4 V5


Active member
Have you run out of com ports?

Every time you connect a usb device to the PC it allocates a com port to it so that the next time it knows the device, eventually you will fill up the com ports and you will have to delve deep into device manager and delete some of the allocated ports to free them up, this is why on some programs, you'll get a list of com ports and some have reserve next to them. Most people never manage to fill up the com port allocation, but us lot with our numerous FTDI adaptors, Arduinos, flight controllers and modules can.

I'm really sorry but I'm not anywhere near a PC to refresh the way to do it but it involved going into device manager and enabling an option that displayed allocated resources, then deleting some of the reserved com ports, I had this before with an omnibus f3, it would let me flash it, but when I connected it normally the port settings on the top right of beta flight didn't change and I eventually chased it to there being no more com ports available, deleted some and after a reboot, it connected fine.

I'm not saying this is your problem, but it might give you an idea, it wouldn't be the boot button being stuck, if it was it would just be listed as DFU in betaflight.


Build cheap, crash cheap
Every time I have not been able to connect to a board it has been a driver issue. The flashing process takes place with a different driver as far as I know so it's possible to be able to flash but not connect normally.


New member
I just went through a good bit of hair-pulling-out with my Tiny6.

I assume you’re more knowledgeable than me and probably already know this but figured It throw it out there anyway because it confused the crap out of me.

When you download the drivers from the links in Betaflight, you have to then go to that file and “unzip” it.

Then you have to open the unzipped folder and find the actual installer program and run that.

I thought once you downloaded from the link, it was done. But nope. Two more steps.