• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Can't bind

#1
Hello I have a eachine qx65 spectrum configuration, I updated the firmware of the drone an betaflig to the latest version and now I can't get it to bind again, I used the command set spektrum_sat_bind=9 for dsmx and nothing can you help me please.
 

FDS

Well-known member
#2
You have an onboard DSMX receiver, you might have to do the bind manually. The button is under the canopy.
Also I hope you saved the initial configuration, diff all in CLI and saved off the main screen, because if your QX65 has an F3 processor then those are not supported in BF4.0 onward. You might have to reflash an older version of BF if all else fails or restore the factory settings.
 

FDS

Well-known member
#4
Did you save all the original settings before you replaced the firmware in Betaflight? Otherwise you are going to need to find all the original CLI values.
It does have a button, that board has been the same for ages, you need to take the shell off it to see the button.
1569086449951.jpg
@Ihichi Bolls am I missing anything?
 
Last edited:
#5
No, I saved after, it was bound but the controls were all wrong and I tried to bind it again, that's what i made it lost the bound. you know what I mean?
 

FDS

Well-known member
#7
Right, let’s get back to basics. What radio do you have? When you looked in Betaflight did you check the channel order in BF matched the channel order in the transmitter? You check that by moving the sticks whilst in the Receiver tab, after binding, to check that they work the right way.
Spektrum uses the channel order TAER (Throttle,Aileron,Elevator,Rudder) but other companies use AETR (Aileron, Elevator,Throttle,Rudder) and BF sometimes sets that as the default order.
You can change it by selecting the correct order in Betaflight.
If you saved the original set up, all you need to do is re flash the correct release of BF, e.g. BF 3.5.7, then copy the CLI from the .txt file and paste it onto the CLI window, hit save. You can use “restore” button in the main BF screen to re set the other stuff like modes. You now can’t do that because you haven’t saved the defaults.
Have you done a full chip erase and firmware flash in Betaflight? If not then it’s not lost the original settings, you just unbound it or changed something that stopped it seeing the TX.
Original CLI dump is here- https://www.rcgroups.com/forums/showpost.php?p=39156820&postcount=2
You should watch this too-
 
Last edited:

FDS

Well-known member
#9
Be sure to back the whole set up onto your computer somewhere.
2nd Rule of Quad, if it ain’t broke don’t fix it!