• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

DJI F550 Hexacopter wobble too much on flight

dr3n3al

Junior Member
#1
Hello Everyone
I just finish re-building a F550 Hexacopter after a big crash, replaced the damaged ESC and propellers, I am a newbie and no one i know has experience with Hexacopters, only with Quads.
When I take off slowly (on GPS, i have not tried on manual) it tends to do a 360 on the ground(crash upside down), I am fine tuning my skills,
I configured the NAZA and calibrate the GPS is all good on the screen BUT on flight it wobbles too much

is it a CG issue?

I flew with a 3S battery and then with a 4S battery
any advice?

I want to make sure it works properly before i put the GoPro on it.
Thanks

you can see it here
 

joshuabardwell

Senior Member
Mentor
#3
Is it possible you have one prop installed backwards, or otherwise somehow one motor is not creating thrust? Perhaps this would cause the flip over on takeoff, as the FC struggles to compensate with the other motors?
 

dr3n3al

Junior Member
#4
Is it possible you have one prop installed backwards, or otherwise somehow one motor is not creating thrust? Perhaps this would cause the flip over on takeoff, as the FC struggles to compensate with the other motors?
thanks joshua
>checked the CW and CCW direction of the motors, all good
>checked the bullet connections to the ESC, i found one loose, all good now
>check the gains, seems like they were too low, i modified them according to recommendations but they are for 8" props and i have 10" props so i will see how it behaves.

Thank you all for your help
 

cranialrectosis

Faster than a speeding faceplant!
Mentor
#5
My first thought is I gain too high, but since you replaced ESCs, I gotta ask, are all the ESCs the same make and model and have they been synched?

Have you balanced your motors after the repair?
 

dr3n3al

Junior Member
#6
My first thought is I gain too high, but since you replaced ESCs, I gotta ask, are all the ESCs the same make and model and have they been synched?

Have you balanced your motors after the repair?
To answer your questions:
> actually, the gains were too low, i used defaults and got really unstable
>Yes, i managed to get the same ESC , brand and amp
>DJI ESC cannot be sync factory set
>i will try to check if i can calibrate the motors for vibration

Thanks for the ideas