• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Does my DX6i not work with a Horizon Hobby UMX A-10 bind and fly?

#1
I just picked up a Horizon A-10 thats a bind and fly. I can get everything BUT the throttle to work. Aileron, rudder and elevator all work, as does the AS3X, but the throttle does not work. Anyone with a similar problem or issue? The guy at the store assured me a DX6i would work with it... well he was 70% right lol
 
#2
Also, I did some hunting before I posted this and noticed people with similar problems with a horizon hobby Cub. However they had to go in to mixing and jimmy different things around and said there were certain switches that needed to be on, etc. I'm lost here. I tried calling costumer support, he told me to lower my trim to minimum and bind with the throt all the way down. I did that and still no go
 

JimCR120

Got Lobstah?
Site Moderator
#3
If your controlling your control surfaces then I don't think it's a binding issue. I'm thinking your problem is in the transmitter, the receiver all-in-one board, or the motor. First check your transmitter settings. Check your throttle cut if you have one and the throttle curve. If you have access to another transmitter you can use that to rule out problems with the airplane.
 

TazRC

Obsession, not hobby
#4
First and foremost, go into your transmitter's monitor function screen and see if the throttle channel is moving.
 
#5
Hey taz, thanks for the reply. Yes indeed it sure is moving. fully left and right. The guy from horizon did that check with me on the phone. I also rebound the plane with my throttle all the way down as well as with the trim to its lowest point until it stopped beeping
 

TazRC

Obsession, not hobby
#6
Did you bind on a new or reset model position in the radio? Also make sure the throttle channel is not somehow reversed. Outside of battery condition, that's about all I can suggest. Did Horizon offer to swap it out for you?
 
#7
I made sure i wasnt reversed, yes. I just flew my pietenpol and biplane from flitetest that morning. I used a new, completely reset position. its so bizzrre. And yes, they offered a swap. The guy actually told me to keep the current one because ill be needing it for parts. Excellent customer service to be frank. I've never had an issue binding anything before, so it totally boggled my mind. I'm still trying to jimmy things around in hopes its user error (which seems likely, since im a bit of a shitbrain at times.)