• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

DX5e Trim Issue

USAbro4

Junior Member
#1
Hello all.

I just got the Aprentice S 15e after owning the mini super cub and the parkzone um p-51d. The DX5e is however, my first full range digital tx. All has been well after recieving the RTF setup on friday. I flew it and it worked. Now, however, the radios trims do not function or even beep, although the radio does turn on, bind, and fly the aircraft. I don't know if the transmitter is defective or what? Also, if anyone knows how to do buddy boxing from it to the hobbyking orange tx please help. Thanks?

P.S. I have a good amount of rc experience, proficient piloting skills, and have looked at the obvious before asking!
 
#2
Certainly sounds munted. The DX5e is as basic as you can get, so it's not like the sound it muted and the trim increments are turned down to miniscule (which is a possible combination on the DX9 if you had some sort of reason to do that, or the factory defaults are wrong).

I'd be putting that Horizon warranty card to good use.
 

USAbro4

Junior Member
#3
Certainly sounds munted. The DX5e is as basic as you can get, so it's not like the sound it muted and the trim increments are turned down to miniscule (which is a possible combination on the DX9 if you had some sort of reason to do that, or the factory defaults are wrong).

I'd be putting that Horizon warranty card to good use.
I think I might, but the beeping still works when the tx turns on. Also, the sound is not only the problem. The trims don't even function.
 

jetpackninja

More combat please...
Mentor
#4
Yup, call the Horizon service department. Horizon service is excellent. Under warranty or not. Just curious though, is it all four trim buttons that don't work?