filament not extruding problem solved and then solved again (a lesson in discovery learning)

Robert S

Well-known member
(ENDER v2 with Direct Drive Extruder Upgrade)

BLUF: if your extruder isn't extruding, check to make sure the feed wheel is fastened to the stepper motor shaft. Also, make sure that the feed wheel is positioned correctly on the shaft so that it can grasp the filament and feed it through.

I started a print this weekend that seemed to be going well. Then after coming down to check on it, I found my filament just dangling next to the head and the printer was just running without any filament. After stopping and reloading the filament, I started the print again and noticed after a few seconds there was no filament coming out of the extruder. I played with it for a minute, but its the wife's 40th birthday weekend and I had to execute a night's worth of eating, drinking and general frivolity.

Fast forward until today when trouble shooting started again. The extruder stepper motor seemed to be turning. I cleaned the tip a few times and then just said, "screw it" and changed the tip. I could manually push the filament through the extruder and it would come out the tip just fine. After scratching my head I decided to just take the extruder stepper off and, if I didn't see anything obvious, I'd take apart the extruder too if necessary.

As soon as I pulled the screws out of the extruder stepper (so that it came off of the part that rolls on the gantry) something very small fell out onto the floor. It turned out to be a very (very) small hex keyed set-screw (pic (1)) that I vaguely recognized. Then as soon as I looked at the feed wheel, I knew what the problem was. Of the two screws that holds the feed wheel to the shaft of the stepper motor, one had come out and one was about to come out (pic(2)). I put the screw back in (with a little blue lock tight) and put it back together. The extruder seemed to be working now, but the test prints looked very bad. I stopped them before the first layer was done. I checked Z axis, I checked slicer settings and temps, but it just didn't seem like enough material was coming out and the material that did come out, wasn't sticking very well. I took apart the stepper motor again and realized that the feed wheel has to be pulled up the shaft a bit so that the knurling can grab the material (Pic(4)). That fixed it.

(1 ) View attachment screw close up.jpg Benchy for size reference
(2) View attachment screw missing close up.jpg
(3) View attachment screw back in close up.jpg Incorrect
(4) View attachment 20230724_205816.jpg Correct


  • thread locker.jpg
    1 MB · Views: 0