• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Gremlin (kit) build, need help with Femto F3

#1
I connected the F3 to the computer, flashed the firmware and confirmed it all worked before starting the build, but then I failed to connect the F3 to the computer after each solder joint, so I don't know where things went wrong. After I was "done" I plugged in and got (blue LED plus) four fast red flashes, two slow flashes and two fast flashes. Obviously that means something!

OK, de-solder everything... I tried solder wick and sucker but the board is just too small to use either. With everything off the board, I connected it and get the blue LED, and the red one flashes slowly. In both cases I have only COM1 and "Manual Selection" where I had another one that worked when the board connected.

IS THERE A LISTING OF "FLASH CODES"? I registered on the EMAX site and asked them, but I'm not hopeful.

Is the general consensus that I let the smoke out? I could get another controller from Banggood, but I won't try this again until the 600x USB microscope arrives that I ordered! I have to order standoffs anyway to replace ones missing from the kit. If anyone has found a better controller to use (with OSD?) I might as well consider using something else too.

Does anyone who has built this thing have a digital temp control on their solder station? What was the successful temperature? I was at 725, using a needle tip. (even that felt like a tree trunk)
 

PsyBorg

Wake up! Time to fly!
Mentor
#2
I have a temp controlled solder station but its not measured in degrees. Its like a volume control that ranges 1-8. For pcbs I solder around 3.5 on the dial. For the battery connectors only I go to 5.5 - 6 on the dial.

If you have too much solder build up on the pads you can hold the board vertical touch the iron to the pad and give a quick gentle tap on the table to throw the solder off the board. That usually leaves me the perfect amount of solder like if I had "tinned" the pad. You just have to make sure the direction of the tap is making the solder go straight off the pad and not cross onto other things.

I too got blink codes when first working with mine but that was because I was getting no connection with the computer due to drivers. Once the board is properly flashed it boots fine. If you got codes after adding an esc but had good connection and no codes with no esc I would think the flash did not fully work OR you may be using incompatible esc's for the base set up.

ATM I do not think you let the smoke out as it is giving error codes. I checked online and various websites that sell the Femtos and as usual documentation is wanting. If you do not like this controller maybe you could look in Litterbugs Dronin thread and use other controllers like the pico BLX or one of the ones he is testing. He has had good success on the Dronin FC's he has been working with.

On a brighter note if you slog thru the setup on the Femto it does fly pretty sweet in these little Gremlin frames.
 

PsyBorg

Wake up! Time to fly!
Mentor
#3
Ok was just looking for some information on what I am doing and came across this.. Hopefully there is a little aid for you in troubleshooting your codes. Found it buried in the wiki write ups.

Why does my Flight Controller blink/beep lots of times when powering up ?

During Firmware Boot-up the Gyro is Calibrated and should give three Beeps/Blinks. This indicates the Firmware is ready. Upon Arming there is one Beep which is from Syncing Video to a BB log.

If gives repeated 2 Beeps this means NO Valid RX - This could be a bad wire to RX, or RX not binding to TX, or TX not yet sending data.

5 short blink/beeps followed by any number of long blinks/beeps indicates an error code. Number of long blinks indicates the following error:
1. FAILURE_DEVELOPER: External interrupt of sensor failed to initialize.
2. FAILURE_MISSING_ACC: Accelerometer/gyro sensor is missing
3. FAILURE_ACC_INIT: Accelerometer/gyro sensor failed to initialize
4. FAILURE_ACC_INCOMPATIBLE: The found accelerometer/gyro sensor is not compatible/not the expected one
5. FAILURE_INVALID_EEPROM_CONTENTS: EEPROM/FLASH configuration content is invalid
6. FAILURE_FLASH_WRITE_FAILED: Write of configuration to EEPROM/FLASH failed
7. FAILURE_GYRO_INIT_FAILED: Gyro initialization of SPI MPU6000 accelerometer/gyro failed

The most common one seem to be error 2 where the accelerometer/gyro sensor can't be found, this is caused by a bad sensor or bad connections to the sensor, could happen because of a bad crash. On most boards gyro and accelerometer is the same chip so acro flying isn't possible when the accelerometer isn't found, it's not just the accelerometer that's bad but the whole chip.

Error 3, 4 and 7 could also be caused by a bad accelerometer/gyro sensor. Error 5 and 6 indicates memory read/write problem of the MCU (main processor). In most cases a new flight controller board will be needed if the user isn't for example able to re-solder the sensor.

Above are Hard Faults the Processor detects upon boot-up and initialization. Additional reasons for flashing LED and/or beeping are:
No signal from RX. This could be simply the TX is off or the wrong Model/binding selected or a hard fault of the RX like no power or bad cable.
Accelerometer Not calibrated if the ACC is enabled (check the CLI). If acc is enabled then it must be cal'ed once and typically done in the config GUI.
Copter titled too far if the Acc is enabled.
 
#4
Moving ahead

Thanks for your input. I suspect my "clever" needle tip on the soldering station worked against me. Yes, it's small, but it transfers heat too slowly so I have to leave it on the pad too long and that over-heats components. Maybe what happened to the accel/gyro?

Nothing changed on the PC between successful connection (pre-soldering) and ghastly failure (after soldering), so I don't know why drivers would suddenly be chowdered. I can try reloading all the drivers again. USB connection was a goat rodeo with APM too! ;) I'll try to put the board in boot mode using the pads, although it flashed the first time without using the pads. (and version reported 3.1.7)

I'd prefer to stick with the Femto F3 if possible because Flite Test has a pretty good video on how to use it. Any 20mm board is going to be tough.

I expected to get the same (LED) result AFTER de-soldering everything as I had before soldering anything. All that's connected now is the pigtail to power the camera -- two wires going nowhere, so I don't know why that would make a difference. I am not sure about the component ridiculously close to the negative buzzer pad -- is it supposed to be connected, or not? I'll have to employ a VIRUS to do that soldering! HobbyKing has the Femto. So does Banggood, but I'm fed up with their glacial shipping and meaningless tracking!

I have noting to lose by fiddling with this FC some more, and without any diagnostic info from the manufacturer, I'm in the dark anyway. THANKS ALL!
 
#5
More messing around...
I tried shorting the boot pads, but it does the fast blink only. I did notice when I plug it in now, the blinking red LED stops when I hold it level, then starts again when I move it off axis. Never connects to BetaFlight, so beyond a "level indicator" it's now useless!

Ordered another from HobbyKing... By the time it arrives, I should have a USB microscope to help me solder to it. I'll use a larger tip, and re-connect it to the computer after each solder joint!
 
Last edited:

PsyBorg

Wake up! Time to fly!
Mentor
#6
Put solder blobs on the boot pads. Mine seemed to have a coating and did not make for easy shorting with a screwdriver or piece of wire like TJ did. The solder blobs make it easy to stick a screwdriver in between the pads and give a gentle twist. That made getting into boot loader mode much easier for me and a lot less apt to damage the pcb.

As far as flashing if you skim thru my posts in my Bills Law thread I wrote up exactly what it took to get mine talking to teh PC. Maybe you could give that a shot while waiting on the new FC. It will give you practice and maybe even confirmation you have the correct drivers and are ready for the new one when it shows up with no hassles.
 
#8
Just my luck, HobbyKing as it

That's the 2nd thing I should have added to my HobbyKing order last night! :p It's $30 there, not that it matters much. Our time is the biggest investment in all this stuff.

It's a bit bigger than the Femto, but still smaller than the 30mm+ designs. As I move my APM controllers to fixed wing, I'll keep the Flip32 in mind, thanks.
 
#9
My new Femto F3 arrived today from HobbyKing (stuff I ordered from Banggood over a month ago is still not here!) I'm going to wait on touching it until I get the microscope and have a close look at both controllers to see if I can figure out what went wrong with the first one. I don't have the batteries (Banggood sucks) or the buzzer (so does FPV Model) yet, so I can't finish it in any case.

This time, I will re-connect to the computer after EACH solder joint, and use a larger tip so I don't have to leave it in contact as long.
 

PsyBorg

Wake up! Time to fly!
Mentor
#11
I would suggest you start your soldering iron LOW.. and slowly raise the temp a little at a time with a 30 second adjustment period between each ramp up. Watch the solder on the tip where it was tinned and you will see when it melts. Raise the temp just a hair above that and you should be in a safe range to work but not cook the board.

Practice proper ESD procedures when working with things like this. Wrist straps are cheap and are worth the investment to save your electronics.

Tin EVERYTHING first. When doing this clean your solder tip, tin it, set the solder on the pad and touch the iron to it. This lessens the amount of heat transferred to the board and is / was proper manufacturing solder method last time I did electronics assembly.

Strip and tin all your wires. Be sure to put a good twist on each wire before tinning. This prevents straggle wires as well as keeps the width of the tinned wire as small as possible. DO NOT and I repeat DO NOT do like several recent build videos and strip the wires over the FC. There is a high likely hood of stray strands falling on the board when doing this.

Then when all the prep is done and you actually solder the joints all you need to do is clean and tin the solder iron tip, rest the tinned wire on the pad and just touch the iron to the wire. It will sink down into the pre tinned pad and not transfer a ton of heat and will not send solder ball spatter all over the place like you get when feeding solder to the iron on thicker wires.
 
#12
So yeah, my old Femto F3 was "smoked"! I built the Gremlin up with the new one, attached the XM+ and I'm all the way to where I need to change the rotation of two motors in BLheli Suite but it says my ESCs are SiLabs and NOT BLheli. Is there a SiLabs suite?

I can't find one. All the links on programming a SiLabs ESC involve wiring up an Arduino! Do I buy new ESCs now?
 
#14
New Femto, build went fine. BLHeliSuite says: "Found SiLabs ESC (expected BLHeli32)" Are these different ESCs?
I blew several hours trying to figure that out, and finally cut the shrink off the two ESCs that had to be reversed and swapped two wires.

So the thing "flies" now, but it's obvious I'll have to continue testing outdoors because it's not stable at all.

Is there a forum area where people are discussing Gremlin issues?
 
#17
After re-flashing the Femto FC to clear up motor cogging, my Gremlin "flies". Never found any software that would connect to the ESCs, so I just swapped two wires on the two motors that needed to change direction. Zeroed out the drift in the transmitter and got the "model" in the Receiver tab stable.

After all that, this micro files about like every one I've tried or owned -- squirrely. I expected it to be either rising or falling every second with no baro, but didn't expect it to require absolutely CONSTANT correction to keep from shooting off in random directions, even with no wind (indoors). Either PID tuning will help with this, or the technology has not yet overcome the inherent weakness in low-mass low-power quads. I have the ability to bring the thing back each time, but for some reason the Femto controller can't manage it, or doesn't try. Gyro and Accelerometer are both on but with the motors so close together, the problem of stability is much harder than on even mini-quads.
 

FlyingMonkey

Stuck in Sunny FL
Staff member
Admin
#18
Have you set up a switch for Angle and Horizon mode yet?

Otherwise it defaults to Rate mode and yes, that will require constant corrections.

-Fred
 

PsyBorg

Wake up! Time to fly!
Mentor
#19
I have tried the assisted modes with mine inside. Its still a handful and with those battery placement MUST be perfect other wise severe drift will occur.

I was working on modding the horizon mode settings to adapt to indoor flight but that will take time and a bunch of flights before I have it worked out..

I would suggest like FM says get the assisted modes on a switch. Then you can go down a bit and lower max angle to like 5 degrees to start and then lighten up the strength parameters so you can be smooth and not have the FC fight every command you input. Pids WILL play a part in it so keep a serious eye on temps for the motors AND the power wires from the battery to the FC. I got my power feed hot enough to melt hot glue as well as possibly un solder a connection in an adapter I have to use for now. I was flying hard outside and it was close to 80 degrees when I did that so indoor may not be as hard on your gear as I was hehe.

Anyway good luck I am off to troubleshoot mine again and see what I melted.
 

PsyBorg

Wake up! Time to fly!
Mentor
#20
I got mine all sorted out and started working on more docile and stable indoor flight. I posted the write up in my build thread. I put up screen shots and an explaination of what I have done and am doing. So far progress is looking good and I expect to get it more tuned in over the next few hours to where I can FPV around my tiny apartment. Take a peak there and see if what I have to this point helps you tame yours a bit.