• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help!!! First Build. Motors wont run in Betaflight; ESC's not detected by BLHelisuite

#1
Hello Flite Test :black_eyed:,

I am new to the RC hobby. I have just completed assembly of my first quadcopter. Below are the specs.

Specs:
Frame - Armattan Chameleon
FC - Matek F405-CTR (Betaflight 3.2.4 also tried 3.2.1)
ESC - 4X DYS XSD 30a v2 3-5s esc blheli_s (Unknown firmware version as I cannot get them to be recognized)
MOTOR - 4X Rotor Riot Hypetrain Freestyle 2306 2450KV Motor (V1.1)
Rx - FrSky R-XSR
VTx - TBS Unify Pro 5GB V2
Cam - RunCam Eagle 2
Tx - Taranis QX7s

Ok so once assembled I downloaded Betaflight. I flashed the FC (Matek F405-CTR) with Betaflight Firmware v3.2.4. Calibrated the accelarometer and assigned the UART ports. When it came to test the motor direction... with rotors off and disclaimer button clicked I connected my fully charged battery. All four motors twitched for a split second. I proceed to increase each individual slider with no effect, then I increase the master slider with no effect. I take out my voltmeter and check voltage on each ESC positive and negative terminal and I have 16.6V Battery voltage to each ESC. I also checked signal voltage to each ESC and I have 3.3v signal voltage to each ESC.

To troubleshoot further I bound the Tx with the Rx and created an Arm switch on the Tx. I followed the Tx setup to a tee per Joshua Bardwells youtube series. I was able to arm the copter and manipulate the model in betaflight. Once again I move to the motors tab Arm the copter, click the disclaimer, rotors off. The motor RPM's show that they are at idle, but no movement from the actual motor. I increase the throttle and the increase is represented in Betaflight but no movement from my motors.

Somewhere I read that I may need to reflash the ESC's. I download BLHelisuite and using the Betaflight/Cleanflight passthrough, I was able to connect through my correct comport. I choose the readsetup and it says that it cant detect any of my ESC's. I also download the Chrome app BLHelisuite and after readsetup it stays blank.

Is it possible that all of my ESC'S are DOA? Is there a way that I can test the ESC's? Is there a way that I can test my motors? If there is any more information that one would need to help me diagnose this issue I would gladly fork it over. I am anxious to get this thing flying. And just to reiterate I have 16.6V to the power terminals and 3.3V to the signal terminals on all of my ESC's.

Any advice would be greatly appreciated!

Thanks,
Spade
 

cranialrectosis

Faster than a speeding faceplant!
Mentor
#2
When you connect a lipo, do you hear 5 chimes from the ESCs?

That's a beautiful board.

I am a bit confused about which pad is for ESC ground and which is for ESC signal between the RX5 and S1-4 pads. Is it possible these two are reversed?

If you don't know, I don't suggest randomly swapping them and powering up. :black_eyed:
 

ElectriSean

Eternal Student
Mentor
#3
Very nicely specced build :)

It definitely seems that the ESC's signal wires are not connected properly. Can you post pictures of the ESC's and FC connections?
 

French

Construire Voler S'écraser Répéter
#4
Are any of you’re ESC signal wires soldered to the RX5 pads? If so, they need to be switched to the corresponding S1, S2, S3, and S4 pads. The small signal ground wires should share the ground pad with the esc main ground wire.

The RX5 pads are a shared UART pad only used for 32bit esc telemetry.

I agree that photos will help tremendously.
 
#5
F405 CTR ESC incorrect wiring.jpg

I definitely needed a second pair of eyes on this problem. I have been banging my head against the wall for a couple of days trying to trouble shoot when it was right in front of me. You guys are absolutely correct. I soldered the ESC signal ground to the S1, 2, 3, and 4 pads. The ESC signal wire is soldered to the RX pads. Here is a photo of how NOT to solder your ESC's to the F405-CTR board. Thanks a lot for all of your help! I will solder the ESC signal wires to the corresponding S pad and the ESC signal ground wires to the ground pad and see if that works.
 
#6
Case closed. I ran the ESC signal ground to FC Ground pad and the ESC signal wires to the S1-4 pads. Everything is in working order for the moment. I just need to re-solder the ground pad to make it look more presentable. Thanks again for all of your help! correct F405 CTR wiring.jpg