• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Help? Gimbal not working?

#1
I just got the RTF gimbal from RTF quads ( http://www.readytoflyquads.com/rtf-all-in-one-gimbal ) It never worked from the start, it had a solid blue and red light and a blinking green. No other indications that it was plugged in, no motor sounds or movement at all. I downloaded the GUI and had trouble connecting the Gimbal to it but when i finally did I tried recalibrating the ACC with no effect, so i finally reflashed it. It connected once more after that but now it will not. Sense it will not connect to the GUI I can't flash it with software. The GUI says to check that the software is up to date and it is, I'm 100% sure. Any help please? Idc what it takes just want to get this working. Thanks!
P.S. the gimbals motors activated once while it was connected to the computer but they just buzzed and jerked around.
 

PHugger

Church Meal Expert
#2
We talked about this last night in this thread -
http://forum.flitetest.com/showthread.php?17465-RTF-gimbal-not-workingu

I gave you a link to the manual, particularly the pages with the initialization steps.
Did you perform these?
There were also explanations for the various LED combinations.
Did you use that to determine the status of your controller?

Flashing the controller might seem like a good idea, but you will still need to perform the steps above.



Best regards,
PCH
 
#3
Thank you

Yes I did do all of the steps you provided but with no success, I'm sorry for my lack of communication in that last threat I got very busy. With the lights my gimbal was showing I determined I was having a system error. I could not get the light to stop blinking even after connecting to GUI. Im thinking of sending this product back and swapping it out if I don't have any success soon.

Thank you for all your help!
 
#4
Another quick question

I crashed my quad today, Its fine but my Lipo was bent just slightly about half way down and the package was tore. Is this battery still safe to charge and use? Nothing came out of the battery.