• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

INAV firmware flashing

#1
hi, all i am attempting to convert my trusty nano talon into a better long range plane. So that of course starts with a flight control board. So i purchased a matek f41wse board and am trying to get inav to work on it but when i connect the board up to the inav configurator the it says that i need to flash the firmware. ok no problem but then i go into the firmware flasher page and select my board, the latest version of inav and the correct baud rate so then i load the firmware and attempt to flash it to the board but then it says it has failed to flash to the board. Any ideas?
 

LitterBug

Troll Spammer
#2
What OS is on the box you are trying to flash with? Have you flashed any other boards with that box in the past? Did the configurator show DFU in the serial port box before you tried to flash IT? Should not have to change the baud rate from default. Make sure you have the full erase box checked before flashing. A screenshot of the flashing screen before hitting flash would be good, and possibly one of the error too.

Cheers,
LitterBug
 
#3
im using windows 10 on the computer, this is the first time i have tried to flash inav, and i was able to connect to the configurator but it sent me directly to theCLI menu and said the version of firmware was not supported i think i have the corect baud rate and i did select the full chip erase

here are the screenshots



1591929098212.png
1591929017744.png
 

LitterBug

Troll Spammer
#4
You need to put the board in to DFU mode. If it is still showing COM5, it will not flash. There are several ways to do this. The easiest is to hold down the "boot" button on the board when you plug the USB cable in. The other way can vary depending on the firmware that is already on the board. From the CLI prompt, type "BL" then return. If that doesn't work, type "DFU" and return.

Cheers!
LitterBug
 
#5
when i presed the boot button it would just go into some mode where its solid red and not connect to anything and when i tried to flash the board it said failed to open serial port , and when i typed DFU into the CLI menu it said it rebooted and then did the same thing