• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

kk2 input problem

polodu64

Junior Member
#1
Hi all,

I recently borrowed my friend's F450 running on kk2.
He warned me :
"my quadcopter was working great until one day, the kk2 didn't recognized any pitch input." :(
I said I would try to fix this :
I tried EVERYTHING ! (from unplugging and plugging back the RX to a whole factory reset) : it did nothing ! I am sure the problem comes from the board itself : the channel works fine on the auxiliary input (5th input).
So, before buying a new flight controller, I would like to ask if this could be a firmware problem ? (it's running version 1.2 by Rolf Runar Bakke), or is there any way I could set the elevator channel to auxiliary input, and leave the elevator input empty ? (I've tried searching on the forums, but I didn't find anything...).

Thanks a lot, and fly safe ! :)
 
#3
Are you sure the reciever is acutually outputting a signal on Ch1-4? Maybe try a servo on Channel 1 or something. Just an idea. Otherwise like CharelZa said, you should update to a much newer firmware and if that doesn't work, I'm afraid somthing is broken probably.

Good luck though,
-1387
 

razor02097

Rogue Drone Pilot
#6
Go to the receiver test menu on the KK2 board. If you move the sticks and the numbers do not change you have confirmed the issue. The next step is to swap the problem channel with a known working channel. If the problem does not follow you have isolated the problem to the actual board.

If the board has the problem try a factory reset on the board through the menu (most firmwares have that option if not skip this). If that does not work try flashing the latest Steveis or Kaptain Kook firmware. If that does not solve your issue the board likely has a physical defect. For 20 dollars I would not attempt to troubleshoot any further... you can if you want.. but even if I were to fix it I wouldn't trust a multirotor with it.
 

polodu64

Junior Member
#7
I tried it : the channel works great on the auxiliary input : it only doesn't work on the ele. input : I tried the factory reset (twice) : it doesn't change anything...
I'll try the firmware upgrade once I get my hand on a USB programmer :)
 

Craftydan

Hostage Taker of Quads
Staff member
Moderator
Mentor
#8
If only the pitch input is broken, but you've confirmed the RX signal is functioning, it's likely that port on the board has somehow broken. I'd double check the solder joint on the underside, but that's likely the only thing you can repair easily -- it might be burned out in the chip itself.

The only other simple alternative would be to switch to a s.bus/cppm/spectrum satellite receiver connection (assuming you have a suitable RX), since these only come across one wire, and IIRC, through the aileron/roll pin. For this you'll have to update the ROM to a version with the matching input type -- there wasn't enough memory in the old kk2.0 boards to include them all in one ROM, so you need to load the one you're using.

You could also re-map the inputs in the source code and re-assemble . . . but that assumes you've got the assembly programming background to do it (a fairly rare skill set). IMO, overkill to revive a $25 board.

Beyond this, you're looking at replacing the hardware :(

OTOH, you'd get new hardware :)
 

polodu64

Junior Member
#9
yes, I've tested the connections with a voltmeter : they're ok :)
I'd love to have these programming skills :p
I'll try the firmware upgrade, and if it doesn't work, I'll just buy another one :)
for only $20, I think it's worth it :p

Thanks a lot :D
 

Cyberdactyl

Misfit Multirotor Monkey
#10
I ruined a KK2 a few weeks ago by doing something stupid that sounds similar to the conditions you have.

I was changing some settings for a heavy load and had the low voltage beeper set for 4S low voltage and was using a 3S battery. Instead of taking the time and moving through a few screens and resetting the voltage to quiet the beeper, I just yanked the wire off and continued. Well. . . I wasn't paying close enough attention and the end of the +12V wire's tip (I DID have it covered with shrink all the way) touched something. I heard a mild snap and the screen went blank, but stayed illuminated. I unplugged and rebooted, and the display came back with text and appeared fine, however two of the channels, 2 and 4, died.

My point is, you may have discharged damaging high voltage to the board somehow, through static or from battery power and never noticed it. If I had not heard the static charge sounding little snap, I might not have had any idea what had happened.
 

Craftydan

Hostage Taker of Quads
Staff member
Moderator
Mentor
#11
My point is, you may have discharged damaging high voltage to the board somehow, through static or from battery power and never noticed it. If I had not heard the static charge sounding little snap, I might not have had any idea what had happened.
In fairness, Electro-Static Discharge (ESD) kills and can do so silently -- no spark, no snap, NO VISABLE DAMAGE, but still no life. This is what I expect happened to this board. If you're living in a humid environment (summer in middle Georgia, for instance :p ) it's far less likely, but it still can happen.

I admit I'm generally sloppy with this (I do live in Middle GA so the risk is at "low but still present" for the moment), but a chip can get hit with ESD anytime it's handled, plugged in or unplugged. If the store ships it in a filmed plastic baggie or specialized foam box, that's to dissipate the static and reduce the chance for ESD damage. Good practice would be to try to not touch the circuitry (hold the board edges) or ground yourself before you handle it (touch the chassis of a metal appliance with a three wire plug). In the winter when it's dry, I ground myself regularly, and more often than not get a slight zap from it -- if I'd touched an ESD sensitive board before doing that, it would now be dead.