• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Mamba f405 not getting connected to betaflight

#1
Hi buds,
I completed my build yesterday,
It flew like a beast
Had a few crashes
GPS antenna got disconnected from one of those crashes
When I flew with all battery packs
I connected to my PC to turn off that uart port
It did not connect
I'm using a 4s
When I connected the battery the fc is heating as hell
Vtx is powered on but no video
5v and 3.3v regulator led are working
Gyro and 9v regulator led are not working
I tried to locate the short but not found even one
Tried to flash the fc again with boot button pressed
Nothing happened
Please help!!!
 

PsyBorg

Wake up! Time to fly!
#2
My guess since you crashed there was damage from the GPS stuff getting disconnected. I would look very closely at the flight controller to see if one or more surface mount components got knocked off in which case you are investing in a new FC. Then if nothing shows obviously missing or burned I would check the USB connector as in the last few years they don't seem to be or stay attached to well on a lot of various flight controllers. That you can carefully rewet the solder and get the connection back in most cases.