• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Naze32 and ESC Full Throttle Issue

#1
Hello everyone,

I'm new to the miniquad scene, and just recently built my first 250 class copter. It has a Naze32 Rev 6, Emax Micro 20A ESCs with Oneshot, and 2204 2300kv motors and a 3S battery. I've been trying to set up my quad to fly in Cleanflight. I've been having an issue where when I go to fly and I up the throttle, the quad doesn't run the motors fast enough to even take off, even when the throttle stick on my transmitter is all the way up. Also, when I try to test the motors in the motor testing tab in Cleanflight, the sliders are all grayed out, except for the master switch. I've looked for a while and can't find an answer, any help would be hugely appreciated.

Thanks!
 
#3
I'm not sure how to calibrate my ESCs without the sliders working in the motor test page. I have adjusted throttle max to 2000 and min to 1150.
 

ElectriSean

Eternal Student
Mentor
#4
You should get your minimums as close as possible to 1000. I hate to ask, but in the motors tab you are ticking the checkbox that says you have removed the props and understand the risks?
 
#5
Haha yeah I am checking the toggle. I'll try that with the minimums. How do you know how low to put your minimum throttle? Do you think that the ESC firmware could have something to do with the sliders not working? The motor test tab worked for a little while while I was building my quad, but for some reason it doesn't anymore.
 

ElectriSean

Eternal Student
Mentor
#6
min_throttle is determined by slowly ramping up the motors in the motors tab until they all run consistently, and then adding 10 or so. Obviously not helpful if your motors tab isn't working properly ;) There could be some firmware issues, especially if they aren't all running the same version. The BLHeli Configurator chrome app is the easiest way I've found to setup and flash ESC's, definitely check it out.
 
#7
Awesome thanks for the advice ElectriSean! I'll check that out and reflash my ESCs, and hopefully that'll work. I'll make sure I adjust min throttle and report back.
 
#8
Ok I'm actually having an issue with BLHeli Configurator... When I press Read Setup, nothing happens. When I first power up my ESCs, they don't give the startup beeps, but when I hit Read Setup, then they do.
 

ElectriSean

Eternal Student
Mentor
#9
I think being connected to the computer puts it into programming mode. After you plug in the battery you read setup, make your changes and write setup. Once you disconnect from the configurator you should get the normal startup tones.
 
#10
What I've found is that apparently my Emax ESCs are incompatible with flashing through the Flight Controller. The programming screen in the configuration just doesn't show up after I click Read Setup
 

ElectriSean

Eternal Student
Mentor
#11
That's a bit frustrating... I know the 12A Emax ESC's on my versa can't be flashed at all without removing components from them, but at least they work ;) Does Emax sell a programming tool?
 
#12
I'm not finding one... that means I'll have to flash them using an Arduino and BLHeli Suite, correct? Or do you think there is another option other than reflashing them?
 

jhitesma

Some guy in the desert
Mentor
#13
emax "blheli" esc's aren't the same blheli you're used to. Emax modified the code and not really for the better. It's based off an older version of blheli and has some changes pulling in even older code. But the bulk of their changes were to modify it to work with their programming card and stick commands instead of the standard blheli programming methods. You can reflash them with normal blheli but will have to do so through the "C2" programming pads. Even once you've done that passthrough/1-wire style reprogramming/flashing won't work unless you remove a cap from the signal line - which IMHO isn't worth it since that cap is there to help filter the input signal. Would you rather have a more reliable/stable input signal when you're flying...or an easier time flashing? If you're more interested in tweaking settings than actually flying...then it makes sense, but personally I'm more interested in flight performance.

You should still be able to recalibrate the ESC's with throttle commands - but I have no idea why your motor sliders wouldn't be working in Cleanflight as I've never seen that happen. But it almost certainly wouldn't be due to the ESC's and is likely something within cleanflight. I just don't fly any of the *flight variants anymore so don't know what's going on with it that could cause it to grey out the throttle sliders.
 
#14
Ok, thank you! I'll try reflashing them through the C2 pads, but won't remove the cap from the signal line. I agree: flight performance is definitely more important than tweaking some settings. I'm going to try recalibrating my ESCs manually using my receiver, and see if that makes a difference, since I can't calibrate using the motor sliders...
 

jhitesma

Some guy in the desert
Mentor
#15
Ok, thank you! I'll try reflashing them through the C2 pads, but won't remove the cap from the signal line. I agree: flight performance is definitely more important than tweaking some settings. I'm going to try recalibrating my ESCs manually using my receiver, and see if that makes a difference, since I can't calibrate using the motor sliders...
The problem with calibrating from the RX is that then they're calibrated to the RX not to the FC.

Remember it's the FC sending signals to your ESC's on a multirotor not the RX the RX only talks to the FC. So that's why it's best to use the FC to do the calibration.
 

ElectriSean

Eternal Student
Mentor
#16
So I just had a look in Betaflight, and all my motor sliders are greyed out. They still work though... In any case, you use the master slider to calibrate all of them at once. Give it a try :) If it doesn't work, can you post a screenshot of the motors tab?
 
#17
Ok, good news! I figured out that my motor sliders were greyed out because my minimum command value was set to 0. I had set it to zero because at the default value of 1000, my motors would continually spin, even when not armed. I set minimum command to 1, and the motor sliders work now. However, I still have the issue of the motors still not spinning at full power under full throttle. I tried recalibrating the ESCs, but same result...
 

ElectriSean

Eternal Student
Mentor
#18
min_command should be set to 1000 unless your ESC's are truly strange... Are you sure your props are on correctly? If they are upside down the quad will behave like this.