• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Naze32 stuck in failsafe

Crash-n-Learn

Where's my hot glue?
#1
Hey guys I need some help.

My naze board has been stuck in failsafe and I have no clue how to fix it.

In cleanflight I get a response from each of the channels under the receiver tab, which means I'm getting a signal but the naze is still in failsafe.
 
Last edited:

HawK86uk

Professional Amateur
#3
Have you tried disabling fail safe in CF, saving, then re-enabling it?

Also, you've not got Fail Safe bound to an aux channel that you've got switched on on maybe inverted? I've had my arm on a switch and inverted once without realising.. Talk about scaring the daylights out of me when that thing just bolted into the air!
 

Crash-n-Learn

Where's my hot glue?
#4
I havent yet. I am really hoping this is a software issue otherwise I'm completely out of the hobby for a while. I'll have to try after school tomorrow.
 

Crash-n-Learn

Where's my hot glue?
#5
*resolved*

Reflashed several times with cleanflight and that didn't work.

Poked around a bit and used betaflight instead and it worked.
therefore it must be a glitch with cleanflight.

Thanks for the help guys!
 

PsyBorg

Wake up! Time to fly!
#6
Clean flight is usually really stable. Software glitches just like in a computer. Sometimes it can take several retries to get things to be happy. You would probably be OK going back to CF if you don't want to worry about the new features being tested in Beta flight to be an issue.