• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help! Need help with receiver

#5
I have the same issue! Sorry to hijack this thread...
I’ve been out of the rc scene for a yr or so... just bought an new rx4r. First time using a receiver without a motor. With my older 4xr relievers I’ve applied power to one of the 4 slots of pins and used the other 3 for the servos. BUT the x4r has the SB on that one used... whereas the rx4r does not! Can I supply the power to the rx4r via pin set 4 and then connect the servos up to pin set 1 & 2? (Elf DLG glider 2ch)
Otherwise, do you need to power the receiver using the connector out of the top?
 
#8
Thanks for the YouTube link... but not sure how that helps as it’s for the x4r not the rx4r and it doesn’t show power connected to it.
 
#10
Read through that thread before, well skipped through.
Ok thanks all, thought it would be a simple question! I’ll ring the shop Monday!
 
#12
Read through that thread before, well skipped through.
Ok thanks all, thought it would be a simple question! I’ll ring the shop Monday!
As already noted, the manual shows the pin outs. I‘d be adventurous and plug your power source BEC or what ever into the servo 3 connector and see if it powers up. If it doesn’t, then you have to use the power leads on top.
 
#13
the videos show the conections to the pinouts on the xr4, I see no reason to assume your rx4r doesnt connect the same way and I would also be adventurous and see if you can power it from the pinouts, if not I looked at the manual and clearly there is a + & - on the board you can certainly power up the system with a ubec
 
Last edited: