• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

New Graupner MZ-10 and GR-12L binding issue.... please help

#1
Wearing the total Noob hat tonight. I am having trouble binding my MZ-10 with the GR-12L. I've been over the vague instructions repeatedly, I've searched the web. I contacted Openhobby.com (awaiting their response), I've looked over forums far and wide. Looking over the previous posts by others on this matter here in this forum, the same question has been posed over the past couple months, but there are no answers as of yet that I could see:

We've each purchased the 'Everything you need Tiny Trainer GET Started package'
https://store.flitetest.com/tiny-trainer-get-started-package/

... but upon attempting to bind, getting no results. The MZ-10 just gives extended fast repeating beeps and the GR-12L rx flashes red LED in complex patterns.

Could someone please help me bind the rx to the tx and get this tiny trainer set up for flight?

Thanks
 
#2
Sorry to hear you are having trouble.

To bind have both the mz-10 and GR-12L switched on. Make sure that there is at lease 2-3 feet distance between the TX and RX when doing a bind. The GR-12L RX is a very sensitive receiver and close proximity to the TX may make it difficult to bind and the TX may generate 3-4 beeps basically indicating signal strength issues. Also have the trainer switch set to normal (switch down).

The red LED light on the GR-12L is most likely on, so press the SET button until it turns off and then press the mode button on the TX. It's a matter of coordination. With the GR-12L the LED light should be off when the binding was successful and the orange bind light should be on.

Let me know how that worked for you.
 

earthsciteach

Moderator
Moderator
#3
I can attest to the fact that the Graupner is an extremely friendly tx in terms of binding. Every tx has its own quirks when it comes to this. Hit me up on PM if you need help!
 
#4
I'm in the same boat (both as a total noob and with the binding). Purchased the same Tiny Trainer package for my 12yo son for Christmas, but we can't get it to bind. Confirmed the trainer switch is set to normal, tried moving the TX and RX farther apart. Tried everything we can think of (short presses of the buttons on TX and RX, long press and holds, alternating patterns, etc.) but no luck. Feeling both frustrated and disappointed that this is supposed to be an easy step! Any ideas what else to try?
 
#5
Like garblezouth I bought the tiny trainer package for my 13 year old son and I to make the transition from toys to hobby grade. The documentation for the Graupner products leaves a lot to be desired. For an entry level radio you need entry level instructions that have been translated by a native English speaker. Also the errors need to be removed such as the reference in the MZ-10 manual to the GR-12L having a green LED. That was very frustrating until I downloaded the gR-12L manual that indicates the LED is red.

The Flite Test guys seem very optimistic about Graupner products so we're going to be patient on this and will be depending on the forum experts to get us through this.

Initially we were watching the build videos as we constructed. I totally missed the assembly guide which looks like will probably address most of my questions/concerns:

http://fr.zone-secure.net/11829/124085/

I may be hitting up you experts later for assistance.
 

pressalltheknobs

Posted a thousand or more times
#8
*bump*

We're still unable to bind our TX and RX. Please help!

If you followed the binding instruction carefully it doesn't work you may have a bad unit. I would make sure you didn't miss something and then contact Flite Test directly.

http://flitetest.com/pages/contact-product

Just in case... The RX must be powered to bind. You power the RX via the ESC. The ESC is plugged into the battery. The battery should be fully charged. The ESC supplies 5v via the red/center wire.

I don't have one but the steps seem to be..

1. Connect the ESC servo lead to the Throttle channel on the RX - I think CH1 but it doesn't matter. Make sure the "servo" plug is the correct way around so the white (or orange) wire goes to the signal pin. A light may come on on the RX. Seems like it is solid on this RX but possibly it flashes.
2. Connect a servo to a channel to test, say CH3 (elevator), making sure the "servo" plug it the correct way round
3. Power on the TX and make sure the trainer switch is off - "Normal" position.
4. Power on the GR12L RX by plugging the battery in to the ESC battery plug
5. Press and hold the bind button on the back of the TX
6. With the RX about an arm length away from the TX, press and hold the bind button on the RX.
7. After a while the light on the RX should go out. (On most Graupner RXs a green light comes on but not the GR12L )
8. A light on the TX should light up (seems it may be orange) and the RX should now be bound
9. Release the RX button.
10. Switch off the TX and release the TX button.
11. Disconnect the RX from the battery. Power the TX back on and reconnect the RX to the battery.
12. Test the channel that has the servo plugged (CH3) in by moving the associated stick (elevator)
13. If it doesn't work repeat in case you missed something.
 
Last edited:
#9
Appreciate the help, but we're getting nowhere. Hopefully a bad unit... otherwise we're really helpless :p

Will contact FliteTest support to see about an exchange.
 

pressalltheknobs

Posted a thousand or more times
#11
I updated my "seems to be this" step reflecting what the video said. Basically the trainer switch needs to be in the "Normal" position and don't release the TX bind button before switching the TX off. I added cycling the power for the RX also just for good measure. It shouldn't hurt since the bind is supposed to persist through power cycles. It's required for some systems to bind properly although the graupner instructions make don't mention it so it may they may not.
 
#12
@pressalltheknobs, thank you so much for your help. I really appreciate the effort.

@flyingmonkey, YES, THANK YOU! That was it! Problem solved!

(Still haven't heard back from FliteTest support, but I guess that's a different issue...)