• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Nothing will bind!

#1
I have just started getting into FPV building. I bought a Taranis Q X7 and have been flying sims while I built my drone. Well I finally got everything put together and I cannot bind my Frysky XM+ D16, I even bought a second one just in case I broke it and they both won’t bind. I bought a TinyHawk to hold me over til I figured out what I did wrong and I can’t bind that either! I did a firmware update to OpenTX 2.3.1 and now only have XJT available under my internal RF in my controller. In every tiny hawk video I watch I need to set it to D8 and it’s just not an option anymore. I Don’t know what to do, I’m getting incredibly frustrated! I have this awesome FPV drone that I can’t fly because I can’t bind it, I have a Tinyhawk I can’t fly because I can’t bind it, and I can’t find anything about getting open TX off my radio! Please somebody tell me what to do!😭
 

Attachments

PsyBorg

Wake up! Time to fly!
#2
If you lost modes or control over the internal transmitter I would suggest reflashing back to what you had on it before to start. I would remove the module in the back as well during this process. specially now as you may end up flashing that as that is the only thing the radio sees atm.

Once you get back to normal operation as it was come back and we can see if we can solve the binding issues.
 
#3
I don't have an external transmitter or module in the back? How do I know which one is the old firmware? I kind of just followed a YouTube video without really understanding what I was doing.
 

PsyBorg

Wake up! Time to fly!
#4
ahh sorry mate I misread and thought you had a module in it as well. Anyways it still goes back to having to reflash to an earlier version. I am not totally sure but I think (think) there is somewhere in OTX companion or in the radio itself to be able to default back to what it came with from the factory.
 

FDS

Well-known member
#5
Firstly have you checked your receiver firmware? If you have a “non EU” transmitter and are trying to bind to EU LBT D16 then it won’t work. You need to have matching firmware on the radio AND receivers.
Open TX version is not your problem. You can check what the internal transmitter module is flashed with. Then you will have to flash your receivers to match if they are off. Check the receiver packaging, it says LBT on it if it’s an EU one. They won’t bind with non LBT. Also if you put Frsky Access on the radio that won’t work with older receivers or D8.
The THF is an SPI receiver, so it just wants D8. Looking at your screen all I can see is that is that both my radios don’t have “XJT“ in front of the protocol. I just have D8, D16, D16LBT and LR12. XJT is the internal chip with the FRsky protocols loaded on it. That one should connect fine, go into Betaflight, check you have “ SPI RX support” and Frsky D selected in the ports tab. Stay in Betaflight then go to the CLI window, type “ bind_rx_spi “ in the bottom command window, then turn the TX on and put it on bind in the set up menu, when it’s pinging hit return on the CLI and it should bind up.
You can set the THF to D16 I think, if it is possible then there’s the option “ Frsky X “ in the ports tab menu.

You need to NOT flash ANYTHING until you have figured out what’s going on, you won’t get anywhere pinging between versions.
Heres a video explaining the protocol thing.

Did it bind before you messed with it?

EDIT: Are you sure the internal module is on? XJT before the protocol is usually indicative of selecting external not internal module. It will still show up like that and allow you to change it even if there is no physical module in your bay. Sorry this reply is a bit disjointed, I keep thinking of new things.
 
Last edited:

FDS

Well-known member
#7
Then it’s a settings issue, double check the internal module is on, run the set up wizard in OpenTX companion and set up a new model to see if it gives you the option of internal module, you shouldn’t have the “XJT” in front of the internal module is the source.
Also check the internal module is flashed with ACCST not ACCESS. There’s no D8 in ACCESS.