• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

One of my ailerons is flapping by itself randomly, video included, help required

#1
My left aileron is twitching up and down without any input. It seems to be random. I have a video included to show you how it looks like. Here are the things I've done to solve the problem

1. Reset the radio's settings to a new profile. Still twitching. (I am using my old DSM2 dx6i)

2. Tried using a different receiver. Still twitching.

3. Tried using a completely new radio. Still twitching.

4. Plugged a different servo into the receiver to see if the servo was at fault, the new servo still twitched.

5. Unplugged all electronic devices in my apartment. All phones off, router off, computer off, laptop off, even the phone I had in my hand had its wireless settings totally off. Still twitching.

6. Checked to see if the servo was just linked badly to the control surface. It was identical to the other side of the the wing in every way. It is hooked up fine.

7. No damaged servo connectors or Y-harness, all cables are sealed as they normally are.


NOTE: This happened to me on a different plane (FT Mini mustand) a few months ago. The same thing. A different receiver, only two different radios, totally different servos. I have no idea what is going on. This problem btw does not affect any of those tiny micro planes like the UMX habu or the blade 120 S, or the blade MCX. Only with my stuff that has a dedicated receiver and only ever with aileron. Switching radios hasn't helped, the same exact like happens.


If can help me I would be super thankful. The weather has been amazing the last few days. I would love to get a chance to fly.

video https://www.youtube.com/watch?v=ikG7Lz4puIo
 
Last edited:

PsyBorg

Wake up! Time to fly!
#2
I assume since you said BOTH servos were centered properly that each aileron is on its own servo? It looks to me like the left one may be set up as a flaperon and is going into flap mode after cycling? If they are set up as flaperon is it possible that one side switch in software is reversed?

I have ZERO experience with a DXI radio but it looks to me like that one side is thinking its a flap since it reverts back to full down deflection after any input has cleared.


Gah disregard.. that whole change radio / new profile thing didn't register..
 
Last edited:

krinaman

Senior Member
#3
Maybe try plugging a single servo in without the y-cable. Possibly there is a problem with the Y cable and/or the other servo causing issues with the one acting up.
 

willsonman

Builder Extraordinare
Mentor
#4
Try swapping out all your servos or unplugging them from the rx one at a time. Sometimes a servo can go bad in the potentiometer but still function and this can send feedback through the entire system and only effect one or two other servos. I've seen it first-hand.
 

bhursey

The Geeky Pilot
#5
Doubt this is it because your really not getting jittering. I had my ESX and servo wires right crossing each other which caused interference. took me about 3 hours to figure it out.
 

Tench745

Well-known member
#6
Does it happen if you have all the electronics plugged in but out of the plane? Is there a y-harness or an extension going to that servo?
 

PsyBorg

Wake up! Time to fly!
#7
Really dumb question...What happens when you take the whole thing up the street? I was wondering as now days we have so many wireless things that your house could be over flooded with RF signals from various things. If there is a product you own that is not properly shielded or outputs a fairly high power signal you could merely be "getting stepped on" to quote an old CB radio phrase.