• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Vortex 250 / bootloader fail / communication fail

#1
Getting no response from the quad, unable to connect to Betaflight.

Trying to use the Vortex Configurator to flash the OSD, and then use Betaflight to flash firmware (Vortex 250 Firmware 1.0.0.52, with Betaflight 3.2.2 )

I press the button on the Fusion board, then power up, and I see a port to the quad in the configurator. When I start flashing it times out, or gives some sort of error (bootloader fail / communication fail)

Any suggestions appreciated.

*Also adding to the problem may be that I recently tried to plug n play a 'ImmersionRC Tramp 5.8GHz A/V TX Module V2.0 for Vortex 250'.
 
#2
first, have you had this flight controller connected to the computer you are using before and it worked.
there has been issues with windows 7 screwing up the drivers needed for the pc to talk to the fc.
i would say as long as the fc lights up 95% of the time it's the drivers on your pc are screwed up.
see this thread https://forum.flitetest.com/index.p...-connecting-to-board.58658/page-2#post-479820
pretty much what you are experiencing

dave
 
#3
I've had it connect before to Betaflight without issue, now no such luck. I'm using a Mac. I've never tried the Vortex app until now... this is as far as I get. It starts flashing, blue LED blinks, and then LED will either turn off or stay solid, it just stays like that indefinitely. I read that some folks would not show a successful OSD flash with the Vortex app, but that it actually would flash the OSD.

IMG_2529.JPG
This is per the manual:

Upgrade procedure for bricked OSD
1) Press and hold fusion board button.
2) Plug Lipo ( while still holding the fusion board button ).
3) Release fusion board button after 2 seconds.
4) Plug to USB
5) Start vortex-configurator from chrome://apps/
6) Make sure the right COM port is selected and press the Flash Firmware button.
7) Point to the update file downloadable from the Vortex product page on the ImmersionRC website, and start the update.
 
Last edited:
#4
i know nothing about mac. still sounds like a communication issue on the computer end. you've had it connected before. same computer? same cable?
 
#5
Per ImmersionRC support they recommended trying on another computer. Sure enough, I could connect (after installing the driver for Mac). Flashed OSD through the Vortex Configurator, flashed new Betaflight 4.0.0.

Had some trouble finishing the TX Wizard - I think because I tried completing it with the previous model I had on my TX and the end points were off. Once I created a new model it worked (when I didn't first complete the wizard none of the Betaflight settings would save).

I thought the VTX module I plugged in was causing some issues so I removed it and put the old one back in, but after the TX wizard with the new TX model I may try reinstalling that module.

After I got the board flashed I was able to connect it to my original computer.

If you update your firmware does that not allow you to restore previous settings from a backup file?
 
#6
the older version was probably not compatible especially if it was before version 3.5.7
so to be safe i would do fresh setup from scratch.
the latest stable version is 4.0.3
there were issues with the 4.0.0 release
 
#7
the latest stable version is 4.0.3
there were issues with the 4.0.0 release
Okay, thanks.

I recall reading something about not going over 4.0.0 for the F3 board - was that just for 4.0.1 / 4.0.2 ? *** Answered my own question from the release notes:

"Users with F3 based flight controllers should upgrade directly to 4.0.2 or newer"
 
Last edited:
#8
per the BF release notes from their wiki
  • unfortunately, bugfixes in the flight controller core functionality have led to an increase of the firmware size, causing it to overflow the available space on a number of F3 based flight controllers. As a result, some features have had to be removed from a number of F3 based flight controllers in order to make the firmware fit into flash. The following targets are affected: AIORACERF3 (#8178).
don't believe that effects you. as long as you have the current configurator, the app that you have on your computer, current version is 10.5.1 for flashing BF 4.0 onward you should be able to flash your FC.
i'm thinking by the next major release of BF that F3 boards will not be supported.

hope this helps
 
#9
Adding the the new VTX had me repeat all the previous steps, update OSD, and then run the TX Wizard, and then updated to 4.0.3 - again had to select a new model on my TX (that step stumped me for a hour+ the first go around).

*With the Spektrum I had to reverse the ROLL and YAW in the settings of my TX.

Thankfully I can now breeze through Betaflight to get all the settings correct. First few times doing that took me like a week and multiple videos/forum threads/etc...