• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Wizard x220 problem connecting to betaflight

#1
Hey guys, so i just bought a wizard x220 and tried to connect it to betaflight but it says "failed to open serial port". I have tried to download the drivers on the welcome screen of betaflight but I am still not able to connect to my drone. What are the list of drivers that I need and that will work on windows 10?
 
#2
did you get the RTF or one where you have to install the Rx?

I got the Rx one... first the plug is plugged into thw PPM and not the sbus...

I followed these instructions... which involved flashing the board to 3.1... he setup the video a bit backwards... start around the 21 min point... flash the FC then go back to the start and set things up... took me a bit of time to get it all sorted but it flys well (considering how bad of a pilot I am)... I've got mine set to change flight mods with a 3 way switch (don't recall the names but auto lvl, acro, and the auto lvl that lets you do flips)
 
#4
thx for the tips but my problem is that I can't find the correct drivers or they dont work. The impulserc also doesnt work on my windows 10 pc
 

ElectriSean

Eternal Student
Mentor
#5
Are you sure you're using a proper USB data cable? Some cables are for charging only. Does the computer "ding" when you connect the cable?
 

PsyBorg

Fly Angry
Mentor
#6
I will second Sean on this. Its almost guarantee that you have a wrong or bad cable if you have tried normal drivers and the driver fixer tool and get no response at all.

I had that same issue when I first started out. I actually took a flight controller with me to Walmart and asked if we could plug the cables in to make sure we had a data cable and not a charge cable as even some of the "Data" cables on the rack actually were not data capable.
 
#8
oh ya... I had issues with the drivers on my main desktop... I was able to get it working on my wife's computer (both win10)... was easiest getting it working on my chromebook though... my 9 year old macbook also had no issue... although I def recall some issue with having to update to betaflight 3.1 to get it to actually work/do anything on anything.