• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Cleanflight 1.9.0 has problem storing servo settings...

kenpenner

Junior Member
#1
Hey guys,
Just finished my Electrohub Tricopter and had a problem with the tail servo and gyro being reversed. The servo tab in cleanflight had a Normal/Revese setting but it would not save when I changed it to reverse.
After a little Googling I found this and it worked for me.

under the CLI tab type in:
servo 5 1100 1900 1500 101 -1
<return/enter>
save
<return/enter>
Then go back to the servo tab and you will see reverse has been changed.

Can't wait to maiden tonight after I get home from work
 

narcolepticltd

I unbuild stuff regularly
#2
might be something you want to bring up in the cleanflight IRC... I've not messed with my tricopter in a while now, but if I make time I'll update to 1.9 and see if I have any issues with it.

Welcome to the forums btw... another Atlanta drone nerd joins the herd :)
 

gaidin_

Junior Member
#3
It is a configurator issue.... CleanFlight 1.9 Servo Reverse

They know about the issue and have put in a fix over at Cleanflight. Should be implemented in the next release of the Configurator. Till then the command line in earlier post can properly save the yaw servo reverse setting with 1.9.
 
#4
Hey guys,
Just finished my Electrohub Tricopter and had a problem with the tail servo and gyro being reversed. The servo tab in cleanflight had a Normal/Revese setting but it would not save when I changed it to reverse.
After a little Googling I found this and it worked for me.

under the CLI tab type in:
servo 5 1100 1900 1500 101 -1
<return/enter>
save
<return/enter>
Then go back to the servo tab and you will see reverse has been changed.
..
Same issue here. But your solution doesn't seem to work for me, but maybe I'm misunderstanding something.

I understand the servo number, the min, max , and middle number.
But why "101" instead of 100? Setting the "-1" to "1" didn't reverse my servo. So, can you explain, or provide a link where you found this info?
 

Ajn6699

Junior Member
#6
Changing the 100 to 101 is the key to reversing the servo, not changing the -1 to a 1. I just had to go through this with my new tri.
Hi In have been having the same problem with the eletro hub tri but when writing servo 5 1100 1900 1500 101 -1 I get a message Parse error. I'm getting a tad fed up with "tri"ing to find a answer to this perplexing problem.