• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Naze32 ESCs Will Not Calibrate/ Motors Not Spinning

Snarls

Gravity Tester
Mentor
#1
Hey guys, I would normally troubleshoot this myself, but I am a little tight on time. I just flashed CF back onto my naze after running dRonin for a little bit. I had to short the boot pins to get it flashed, but it connects to CF configurator now. First I went back to CF 1.09 because I had some good settings on that version.

Problem is that I can not get the motors to spin up and the ESCs will not calibrate. I moved to the latest version of CF and same problem. Here are the details:

-RG12a ESCs flashed with Blheli 14.3 I believe.
-First time flying with CF on my Taranis. The same setup flew fine with dRonin on the Taranis.
-I've tried ESC calibration through motor tab and CLI. Not getting beeps at end to confirm calibration.
-Naze makes proper beep sound when trying to arm via TX, but the motors do not spin.
-ESCs use Oneshot and I've tried calibrating with oneshot option selected and not selected.

Since last flying CF all that has changed is my TX is now the Taranis and my ESCs have updated versions of blheli.

Thanks guys, I'll keep trying and will let you know if anything changes.
 

Flying Cirkus

Moderator
Moderator
#2
Rx configured correct?

Modes configured correct?

ESC calibration should be straight forward.. throttle max in configurator or radio, power up quad "no props", escs beeps, power to minimum and confirmation beeps from escs.. done..


For more help try ask in the Cleanflight group on FB or get on IRC and the #cleanflight channel to ask the devs..
 

Snarls

Gravity Tester
Mentor
#3
Thanks for the reply Flying Cirkus. RX showed everything correct in the receiver tab and the only mode I'm using in the mode tab is a switch for my beeper.

Solved: So I actually figured this one out, but I have no explanation. I decided to start from scratch and not load my saved config. I got the RX connected first then went to calibrate the ESCs. This time the motors in the motor tab moved up correctly when I moved the master slider up. I did not even notice that before when moving the master slider, the individual motors stayed at 0. I could not even move the individual motors sliders up. They were locked.

So I then calibrated the ESCs after starting from scratch and finished up the rest of my configuration according to some old screenshots I took. After I finished the motors would not work again. Turns out my custom motor mix was preventing the motors/ESCs from getting a signal for some reason. Reset the mix to basic QuadX and everything works! Took it out for a test flight and it flies as good as I remember. I just have no explanation for why my motor mix caused problems.