• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event
#1
Hi,

after several days of unsuccessful attempts I decided to reach out to this forum, asking for help.

I'm building a mini FPV drone based on the MATEKSYS F405-CTR flight controller - link.

After some reading, I decided to flash BetaFlight firmware on the FC.

My computer is running Windows 10 64-bit, updated to build 17763.529.
MB: Asrock AB350M Pro4
CPU: Ryzen 5 1600
RAM: 16 GB


There's an issue with connecting it to my computer, it seems the system doesn't recognize it at all after plugging the FC in a USB port.
I don't even hear the "USB device connected" sound in Windows, and nothing happens in the Device Manager after connecting it.

LED lights when connected
  • When connected as it is, one red LED stays lit all the time, while a blue one keeps flashing.
  • When connected while holding a button on the FC (which I presume forces it to connect in bootloader mode), the red LED stays lit, and another small red LED turns on. No blue LED.

This is how my Device manager looks like, FC connected.
devicemanager.png

The COM1 port was already there before connecting FC - that's not the FC.

On some other forums I've seen people recommending to download the STM32 Virtual COM Port Driver VCP drivers - since this one is using VCP, not CP2012.
After downloading and installing the STM driver - specifically its Windows 8 version, since there were only Win7 and Win8 versions to choose from and I'm running Win10, the installation finished successfully, telling me the drivers are installed.

STMinstalled.png


However, nothing changed. FC still doesn't get recognized at all. No changes in the Device manager either.

In a Youtube video, some guy used ZADIG software to update the drivers. However, when I tried and followed his steps, I don't have a STM32 BOOTLOADER option in ZADIG's list of devices.
zadig.png

So, I tried to google STM32 bootloader drivers, and after some digging, I downloaded basically the same VCP driver I was installing earlier. So, again, I install them, the message about successful installation appears, and boom. Nothing changed, no progress.


I noticed some people having similar issues were recommended to open Device Manager, find USB Serial Converter , go into Properties and -somewhere- tick the VCP option, to make virtual COM ports appear. Well, as you can see in the image above, I don't have USB Serial Converter.

After searching for a solution, I tried installing VSPD software - Virtual Serial Port Drive by Eltima.
There, I created a pair of virtual COM ports (COM2, COM3). They did appear in Device Manager next to the COM1 port.
However, since it didn't change anything either, I then deleted the pair in VSPD again and uninstalled that software.


Another thing which I tried was going into Device Manager - highlighting Ports (COM and LPT) section - Action - Add Legacy Hardware - manual selection - Ports (COM and LPT) - STMicroelectronics. - STMicroelectronics Virtual COM Port Version 1.4.0.0.
And, it results in a "This device cannot start" Code 10 error. Which is, apparently, a generic and non-descriptive error, coming from a damaged or corrupt driver and designed to ruin my mood for weeks.

STMicroelectronicsVCPcode10.png



Then I found about Impulse RC Driver Fixer software, which should basically find any connected FCs, download their drivers and install them automatically.
Tried it, but it gets stuck on "Searching for Flight Controllers...".. so yeah, that would be too easy, wouldn't it..

_________________________________________________________________________________________________________________________________________


So, I tried the following:
  • Installing the latest CP210x Drivers, rebooting - nothing changed
  • Installing the latest STM USB VCP Drivers, rebooting - nothing changed
  • Installing ZADIG - no STM32 BOOTLOADER option, or any other relevant option in the list
  • Uninstalling every single USB driver in Device Manager, reinstalling them again - nothing changed
  • Several driver updating software (Intel driver updater, avast driver updater etc) - they keep telling me my drivers are up to date
  • Installing STM32 Virtual COM Port Driver - installation successful, nothing changed though
  • Device Manager - Display - Show hidden devices - uninstall every single greyed out device, reboot PC - nothing changed
  • Impulse RC Driver Fixer - doesn't even see the FC
  • Updating Windows 10 and BIOS, nothing changed

Not sure if related, but...
  • I think the issue might lie somewhere in my computer's USB drivers. I'm also unable to use an Arduino UNO board (knock-off, not an original arduino), where all of my attempts to make it work result in the same Code 10 driver error.
Thing is, I really don't know what's wrong. I reinstalled every single USB driver in the Dev.Manager, I made sure my chipset drivers are up to date.. I'm just clueless at this point.

Any help or tip is greatly appreciated.
 
#3
How could this happen to me.. Swapped the cable for a different one and now the STM32 bootloader shows up. Installed the driver in ZADIG, in BetaFlight DFU connection shows up, so I just flashed the firmware...

So this just happened.. I feel kinda vulnerable.. Thanks for your help though, this might be the fastest solution ever.. haha :)
 

FDS

Well-known member
#4
Lucky for you I understand sweet FA about fixing drivers but do understand that if your cable doesn’t join two things it can’t carry data! So glad a simple analogue solution fixed your problem, made my day.
Happy flying!
 

sprzout

Knower of useless information
Mentor
#5
Did you double check that your USB lead is a DATA cable not just a charging cable? Simple but easily overlooked.
This very issue happened to me last week - I had wanted to tweak my Acrobee's Betaflight settings and thought I had brought a data cable with me on my trip. Turns out that the cord I had was a simple USB power cable that was for charging my Kindle, and wouldn't allow me to connect to the FC.

Luckily, my wife had brought an extra cable for her Fitbit charger that was a USB charging cable, and THAT turned out to be a data cable! Same