Flip 1.5 issues!


Junior Member
Hi folks,

I have looked at a heap of posts and cannot find an answer to my problem so I appologise if it has been covered before. I have just completed my first build of the FT Electrohub with the flip 1.5.

I am using a turnigy 9x controller and receiver.

When I calibrated the esc's they worked perfectly and used the full range of my throttle. When I plug in the flip, with my values added to winGUI, the motors don't start until half stick and they do not come on together, if it were to fly it would be doing some crazy charpu flips.

What have I done wrong? It must be an issue with the flip, I have calibrated the acc - still doesn't help.

Thanks in advance,



Winter is coming
On my phone now, so hard to give details. I would calibrate the escs all together via the flip with the special calibration build. Do so after configuring the minthrottle value. I think of you Google multiwii esc calibration and min throttle, you'll find the details. Rtfquads wiki and multiwii.com also have the details.

Ok, on a computer now so can go into more details.

http://www.readytoflyquads.com/the-rtf-wiki and a decent video that describes all this: https://www.youtube.com/watch?v=iry4vaE4RUY (some of the details are for an older version)

Basically describes what you need to do; although, Paul doesn't go into detail about ESC calibration.

Here's the MultiWii docs for MIN_THROTTLE: http://www.multiwii.com/wiki/index.php?title=Config.h#Motor_minimum_throttle

and ESC calibration: http://www.multiwii.com/wiki/index.php?title=Extra_features#ESCsCalibration

Basically, you will need to download the source from Paul/RTFQ's dropbox account for the type of multirotor/mix you're flying -- assuming a quadx, it would be this file: https://www.dropbox.com/sh/3ptxpwes...GF-KaDD1Ua/MultiWii_Flip_NORMALQUADX.zip?dl=0

Assuming you've installed the Arduino IDE (I use the latest 1.6 version, but Paul's site talks about an old 1.0.3), select the board as the Arduino Pro/ATmega328 16MHz, 5V board.

You will load the project (MultiWii.ino or something like that) then go to the config.h file to uncomment the #define ESC_CALIB_CANNOT_FLY line by removing the // at the start. I have my minthrottle with the RTFQuads ESC's that comes with the Electrohub kit (20A Reds I believe) at:
#define MINTHROTTLE 1100

It may seem like a lot, but it's not too bad if you read or watch the videos and take your time. Just be sure to do all this without the props mounted!
Last edited:


Flite is good
Did you set endpoints in the transmitter? I spent some time on the RTFQ wiki to find out that my Futaba 10CAG needed some different than standard values. I will look around there again, if I see a section on your radio, I will post again with links.


Junior Member
I did the calibration and nothing has changed. I think TEAJR66 might be on to something there, I'll check my end points and see how it goes.


Junior Member
nope, ive got nothing!

this is what my motors look like at full throttle:
win gui.png

the left rear is full, the other three dance around, with front right almost as strong as rear left.

Any more help would be great, i'm stumped.


Senior Member
There's nothing wrong with what's going on. You can't look at a multirotor motor output while it's sitting on the ground and expect it to make sense.

By spinning up the front right and back left motors faster then the other two, the craft is attempting to yaw to the right. Lets say it gets confused about where it's head should be pointing and decides it needs to go 1 degree to the right. it begins spinning the front-right and rear-left props faster and the other two slower. The trouble is that there are no props, so its course is not corrected, and it begins to try harder and harder to yaw 1 degree right. Pretty soon two of the motors are at maximum throttle and the other two are almost minimum.

If your props were on, the correction would happen as soon as you jumped into the air. It would not be perceptible to you though.

Similarly, the roll accelerometer is showing slight roll left, which explains why this paralyzed craft is putting more total throttle into the left side than the right. Are you in angle mode?

Another problem is your input channels aren't centered. Rudder, Aileron and Elevator need to be at 1500. Adjust your transmitters subtrims until you are as close to 1500 as possible, then *never* touch the trims again.

The only other mystery is that you said the motors don't start until until your throttle stick is halfway up. Strange. Do you have expo programmed on your throttle? turn it off is so. Send us a picture of your throttle stick and a screenshot of multiwii gui at the point where the motors start.


KI had the same issue when using multiwii config 2.3 i had to reflash my board and hen use Wingui and everything came together and i love my quad now. Message me anytime if u cant get it fixed and i can walk you through what i did to get mine up and running


Flite is good
Did you read through the wiki on the RTFQ web site? Most of the base instructions out there seam to be aimed at people using spectrum radios. After watching the video (found on the RTFQ Wiki http://www.readytoflyquads.com/the-rtf-wiki ) that covered Futaba, my stuff worked. It was all in the transmitter settings. My Futaba and my Turnigy 9X have very similar functionality in the menus ( I have not used my 9x on my quad). I am willing to bet that if you set up your transmitter with similar settings to the Futaba video, it will help. I would try this myself, but I am overseas and away from my RC Gear.


Junior Member
Well I'm reporting back from the field where I have just put three batteries through this bad boy and it flew great! Thanks so much for all of your help.

I just need to work out why my throttle comes on at half stick, I'll send through the images requested tonight. Thank you again,

A very appreciative Dannoz.


New member
Did you ever figure out why the throttle comes on after half stick? I'm having that exact same issue myself. If I run the default settings the thing is perfect, and has been for well over a year. I'm simply trying to assign Horizon level to an AUX channel. Once I do that, then WRITE, the throttle only kicks on after 50%. If I return to defaults, everything is good again.

All of the MIN/MAX values and throttle postions stay exactly the same.

Flip 1.5 with MultiWiiGUI.