• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help! Ft 20 amp Esc random beeping

#1
Hello, I am 15 and just getting into the hobby. I have built a few FT planes before, and this is a new and interesting story.

I got my tiny trainer speed build kit over the weekend. The build of the plane went fine. Receiver binding and servos all worked well. At times, when powered on, after the initial connection to the transmitter and normal ESC tones, the ESC made a noise of two beeps with increasing pitch. This happened randomly, and I could not pinpoint the cause of the beeping. After building the plane, I researched what the cause could be of this strange sound. I came across the idea of throttle calibration. I did calibrate the throttle endpoints, and that did seem to stop the beeping for the five minutes that the plane was connected to the battery. Every time that I plugged in the batteries, they were over 50% battery, so there should be no low voltage problems

Electronics that are being used:
-Lemon RX dsmx 7-channel stabilizer receiver
-Dx6i spectrum transmitter
-FT 20 amp ESC
-Powerpack A electronics
-3s 800 mAh battery

During the maiden, set up on 4 channels, everything worked well. It took a rough landing that required changing the prop. The Last two flights that day ran through the other two 3s batteries. Everything went well that day. The next day, I took it out to fly, and I noticed that the throttle seemed to be cutting out. Around a second later after reducing throttle, I could give throttle again. I couldn't tell If I had control of the airplane, as the throttle cut out when on a level flight. Soon after regaining throttle I definitely had control of the plane. That flight went well with the throttle seeming to cut out about twice. The flight ended with the voltage alarm set at 3.7V per cell notifying me to a low voltage and I had a normal landing, so I was flying with a sufficient battery.

Later that day in the evening, I was flying in a slightly smaller area and I decided to use a 2S 900 mAh battery so I would not go as fast. At this point, the connection sound is still happening randomly. Just before my 2S flight, I was throttling up to launch and the throttle cut out. After the motor cut out and stopped spinning, the same two beep beeping sound happened, and after that, the throttle was responsive again. After 5 minutes of listening for the sound, and it did not happen again, I decided to launch. About 30 seconds into the flight, I was banking and about to yank the plane to turn about 180 degrees. Before I could pull the plane out of the turn, The motor cut out and I definitely lost control of the plane. I lost control and the plane hit the ground nose-first. No damage, just a dirty prop, and dirty foam.

After this, I decided to do a range check on the plane. During the range check, A very faint single beep sounded from the ESC, a sound I had never heard before. A few seconds later, a single, louder beep was heard, again a unique and new sound. After that, the range check was competed and no abnormalities were found.

I have no idea what is happening. Any person that could give a bit of help to solve this would be greatly appreciated. I have a few speculative questions:
Is the 2S triggering the low voltage warning on the ESC that was previously used on a 3s?
Is it actually losing connection? I have perpendicular dual antennas that are supposed to prevent that.
What is the ESC saying with the connection sound after connection?
What is the ESC saying with the single beeps?
If something is wrong with the ESC programming, how do I reprogram it with the dx6i transmitter?
Is there a specific manual for this flite test ESC?

Again, any help would be greatly appreciated in getting my tiny trainer up into the air again.
 

FDS

Well-known member
#2
It’s possible your 2s is under spec, as the 3s will produce the same torque without needing as much current. If that 2s is a 20C or is an older pack it could well be getting down on voltage. The ESC won’t care about input voltage but they do have a throttle cut if the cell voltage drops to 3.5v per cell.
The ESC could also have been put in program mode, if you powered it up with the sticks in an odd position or did something inadvertently. I don’t use the FT ESC’s so can‘t help you.
Also check the motor wire plugs, be sure none have exposed metal at the connector.
There are a number of people who have had the same or similar problems with the FT ESC’s, do a search.
 

TDL

Active member
#3
I don’t know FT ESC specifically, but from my experience dealing with ESC from all brands, the beeping sound after initial alarm indicates either 1) lost of signal from TX or 2) bad connections between ESC and motor. I would re-bind TX-RX or test with another RX. If the symptom remains, then I would check all of the soldering joints and the wires. First to straighten the three wires to the motor as best as you can, plug your battery in, after the initial alarm, advance throttle very slowly until the motor about to turn over; If you see motor barely turns or even slightly turns backward with a weak beeping, meaning one of the three wires has bad connection. Most of the time is happens on the solder Joint, but I have seen broken wires as well.

ESC will automatically detect the cell count of the battery you connected, so a good 2s will not trigger low voltage alarm.

Good luck with trouble shooting, it is part of the fun!
 

Bricks

Well-known member
#4
What everyone said above.

Try rebinding but keep the transmitter away from the receiver I usually put my body between the transmitter and receiver. What can happen is a double bind in other words the transmitter is too close and the receiver binds to a double signal which causes many problems and cuts way down on range. Be sure after binding shut everything down pull bind plug and restart everything.
 

Merv

Well-known member
#5
I'd take a look at your Rx, not sure you are getting a good signal. Make sure there is no damage to the antennas. The damage often occurs where the antennas enter the case. Sometimes Rx's just go bad.
 

Hai-Lee

Old and Bold RC PILOT
#6
I had a similar random beeping and internmittent operation almost 2 years ago and after a lot of searching and testing I discovered that the signal wire between the ESC and the motor wasn't making proper contact all of the time and the beeping was a signal that the receiver connection had been lost.

I replaced the wire and plug between the ES and the Rx and the problem was gone completely!

Just my experience.

Have fun!
 
#7
Solved!
The ESC was not part of the problem. The lemon rx receiver was losing signal from the dx6i transmitter.

While troubleshooting the problem in my house, I noticed that the ESC usually beeped when I was on my phone looking for manuals and information on the problem. Remembering that Wi-Fi and DSM2 are on the same frequency of 2.4 GHz, I pursued this lead. When streaming videos from my 2.4 GHz router in my house, I could cause the beeping problem by walking away from the plane with the transmitter.

Switching to the dx9, which uses DSMX, the signal from the transmitter was not interrupted, presumably from the constant frequency hopping on DSMX. The DSM2 can easily be interrupted by the simple 2.4 GHz signals from routers, as it only uses 2 randomly selected frequencies.

This made sense as I reflected on the locations where I flew. The place that I maidened the tiny trainer was free from any Wi-Fi interference, it was an open field. The place that I was losing signal had houses on the border of the field, in which the routers of the houses could have interfered with the dx6i signal.

Using the dx9, I had four successful flights with no issues. The plane was fine in the field with the houses bordering it, and I hope to have much more entertainment with the tiny trainer.

Thank you to everyone who took their time to respond to this interesting problem. My plane is now up in the air.