• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Gremlin ESC (bl Heli Suite) problem.

pinpoint45

Pants Wearer
#1
So i got my gremlin kit in the mail today and immediately starting going to work, 5 hours later i am almost complete, i have tested the direction of my motors, and 2 of 4 need reversed, following along with TJS build video i launch BLheli suite and attempt to connect with my battery still plugged in, i select com4(which is what betaflight recognized) and hit connect.

this is where the trouble starts
it then prompts me with a box telling me to connect the ESC and cycle power. a black bar creeps across the lower part of the box, nothing happens, i tried unplugging the battery and replugging, and basically every combination of that and restarting the suite. still no connection. so ive looked up about every forum i can think of looking for a similar problem.

i dont know if it has anything to do with BL heli suite but even though i could test my motors in betaflight, and my receiver is sending signal to the board. the throttle wont spin up the motors regardkess of arm switch position. when trying to test without being connected to the PC


any help would be appreciated. thanks
 

pinpoint45

Pants Wearer
#2
OK saw in another FT thread how to fix the motor throttle problem, but i still get the same issue with BLheli suite, and i need it to work to reverse these motors. anybody have a clue?
 

ElectriSean

Eternal Student
Mentor
#3
You can try the BLHeli Configurator app, it's a little more friendly. It's a chrome app, so getting it is the same as betaflight.
 

pinpoint45

Pants Wearer
#5
so i found my problem was the wrong Baud setting so i had to switch to the Clean flight interface to allow more selection in the drop down menu, from there i could set the baud at 19200, it recognized immediately and i could read the settings, and reverse everything i needed, thanks for the tips guys. i hope this helps if anyone runs into the same problem.:D im all ready to fly except that its going to rain all weekend :/