• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

How can I adjust my throttle so that my quadcopter needs less stick to stay up

#1
I have this (admittedly fragile but) nicely flying 230 quadcopter. I'm using the KK flight controller. I can do nice banked turns and stuff, but I need to keep the throttle at 60-70%, rather than the 50% I would expect. I also have to "emergency compensate" with the throttle more than on my 450 whenever I get too close to the ground or if I need to turn in hard. Any idea why this is? Is it something inherent to the size, or a setting in the KK or what? I tried adjusting the travel in my transmitter (Spektrum DX6i) but to no avail.

I'd like to be able to hover at around 40% throttle.
 
#4
Sure, it's a HobbyKing Schimitar 230. It's got 12A Afro SimonK ESCs, "baby beast" multistar 2206-2150 motors, KK2.0 flight controller, 1000mAh, 3S batteries, 5030 diatone propellers. Battery on top, adjusted for proper balance and center-of-gravity.
Weight I don't have, I'm afraid. No scales available. =( The battery weighs 95g, I think. There's nothing extra on it, save for some zip ties, that could make it significantly heavier. The motor and esc combo were recommended for the frame, so I'll assume it's correct. I use CPPM between RX and FC, though I can't imagine it matters.
 
#6
Assuming you have everything correct on your copter, a custom throttle curve is what you are describing to get your stick in the position you want. If 50% of the esc's throttle is what you are after then different propellers or a 4 cell battery may get what you are after. With the throttle curve (if you can do that on your transmitter), you will want it to go from 0 to around 35-40% at around 25% throw and then gradually up from there. I have noticed with my setup, my stick gets to around 15-20% before the motors ever start to spin. I might have a setting to mess with that would fix it, but I have not gotten around to it. If not, what I have suggested will work for me too. Hope that makes sense and maybe help.
 

razor02097

Rogue Drone Pilot
#8
How would I do that, and what kind of result can I expect? Is this the "is it plugged in?" or the quadcopter world? :p Actually, maybe that would be "are your propellers balanced?" =)
No it is a legitimate question and suggestion. If you are using the KK2 board do the following...

  1. Everything powered off and battery unplugged.
  2. Remove your props. Please do NOT skip this step.
  3. power on your transmitter and put the throttle to full
  4. hold the #1 and #4 button on the KK2 board
  5. power on the multi-rotor
  6. wait for the ESCs to beep indicating the full throttle position has been accepted
  7. Lower the throttle to minimum
  8. Wait a few seconds then let go of the KK2 board buttons.
  9. Your ESCs should now be calibrated.

Keep in mind depending on the firmware you have on your board you may have to add a step of selecting ESC calibration on next power up from the menu. So research is advised.
 
#9
No it is a legitimate question and suggestion. If you are using the KK2 board do the following...

  1. Everything powered off and battery unplugged.
  2. Remove your props. Please do NOT skip this step.
  3. power on your transmitter and put the throttle to full
  4. hold the #1 and #4 button on the KK2 board
  5. power on the multi-rotor
  6. wait for the ESCs to beep indicating the full throttle position has been accepted
  7. Lower the throttle to minimum
  8. Wait a few seconds then let go of the KK2 board buttons.
  9. Your ESCs should now be calibrated.

Keep in mind depending on the firmware you have on your board you may have to add a step of selecting ESC calibration on next power up from the menu. So research is advised.
You know, this is actually a great suggestion. I remember doing it on my previous quadcopter, but I seem to have forgotten to do it on this one. Thanks!
 
#10
Assuming you have everything correct on your copter, a custom throttle curve is what you are describing to get your stick in the position you want. If 50% of the esc's throttle is what you are after then different propellers or a 4 cell battery may get what you are after. With the throttle curve (if you can do that on your transmitter), you will want it to go from 0 to around 35-40% at around 25% throw and then gradually up from there. I have noticed with my setup, my stick gets to around 15-20% before the motors ever start to spin. I might have a setting to mess with that would fix it, but I have not gotten around to it. If not, what I have suggested will work for me too. Hope that makes sense and maybe help.
I have a Spektrum DX6i. I'll investigate it's capabilities, but this is the kind of thing I was hoping would be possible. Have kind of transmitter have you done this on?
 
#12
Throttle curves are nice and all, but there is no way your quad should need 70% throttle to hover. Looking at the results here:
http://www.rcgroups.com/forums/showthread.php?t=2203375

at 50% throttle your motor/prop combo should deliver ~200gr per motor. Cant imagine your non FPV, 1000mAH setup to weigh anything like 800gr, so it makes no sense you need more than ~35% throttle. Calibrate the ESCs for a start.
Wow, that's an incredible wealth of information. Nice find!
You're likely right about the calibration, though. As soon as my girlfriend wakes up, so I don't wake her with the beeping, the calibration can commence =)
 
#14
Ok, that didn't help. I just took it out for a pack before the rain forced me back inside. I'm still at around 60% throttle just to maintain a hover. To actually maintain forward momentum, and do turns and stuff, I have to push it up even higher.

What's the next step? Should I try to adjust the travel on my transmitter, or is there something I can do in my flight controller?
 

razor02097

Rogue Drone Pilot
#15
What firmware do you have on your KK2 board?

Go in the stick scaling menu. What is the number value for the throttle? It should be 90 by default.

Go to the receiver test menu. With the throttle on your transmitter down does it say 0 idle? All the way up does it say 100 full? If not use the end point adjustment in your transmitter to adjust those.
 
#16
What firmware do you have on your KK2 board?

Go in the stick scaling menu. What is the number value for the throttle? It should be 90 by default.

Go to the receiver test menu. With the throttle on your transmitter down does it say 0 idle? All the way up does it say 100 full? If not use the end point adjustment in your transmitter to adjust those.
I got it about a week ago, so I think whatever's the newest. I think 2.1.5. There's no menu item that'll let me see this.
Throttle scaling is at 90.
0 at idle, 98 at full.

It's all more or less standard settings. I'm using CPPM, but I doubt that has anything to do with it. If it did, the receiver test would have shown it. I'd need to remap the input. Push the curve. But I don't know if either the KK board or my transmitter allows that. If it does, I haven't found the right place in which to do it...
 

razor02097

Rogue Drone Pilot
#17
I got it about a week ago, so I think whatever's the newest. I think 2.1.5. There's no menu item that'll let me see this.
Throttle scaling is at 90.
0 at idle, 98 at full.

It's all more or less standard settings. I'm using CPPM, but I doubt that has anything to do with it. If it did, the receiver test would have shown it. I'd need to remap the input. Push the curve. But I don't know if either the KK board or my transmitter allows that. If it does, I haven't found the right place in which to do it...
No. Remap is unnecessary. Adjusting your sub trims and end points should have been done as part of your initial setup. The KK2 board can compensate pretty well without doing it but your copter will never be right until you adjust your transmitter to what the KK2 board is expecting.

  1. Go back to the receiver test.
  2. With throttle all the way down adjust your low (idle) subtrim up until you see it change to 1.
  3. Then adjust the sub trim down several clicks until it is back to zero.
  4. Then raise the throttle to full.
  5. Adjust your end point until it reads 100.
  6. Then recalibrate your ESCs.

I also suggest you adjust your sub trims and end points for all of the other channels. You want them to read 0 with no input 100 and -100 with full stick input.


After that you can start your troubleshooting.
 
Last edited:
#18
No. Remap is unnecessary. Adjusting your sub trims and end points should have been done as part of your initial setup. The KK2 board can compensate pretty well without doing it but your copter will never be right until you adjust your transmitter to what the KK2 board is expecting.

  1. Go back to the receiver test.
  2. With throttle all the way down adjust your low (idle) subtrim up until you see it change to 1.
  3. Then adjust the sub trim down several clicks until it is back to zero.
  4. Then raise the throttle to full.
  5. Adjust your end point until it reads 100.
  6. Then recalibrate your ESCs.

I also suggest you adjust your sub trims and end points for all of the other channels. You want them to read 0 with no input 100 and -100 with full stick input.


After that you can start your troubleshooting.
I've done that. My trims are ok. As close to as as they can get. I did that before I calibrated my ESCs. That was one of the first things I did, once I got the CPPM channels right.
 

razor02097

Rogue Drone Pilot
#19
I've done that. My trims are ok. As close to as as they can get. I did that before I calibrated my ESCs. That was one of the first things I did, once I got the CPPM channels right.

Please recheck. you said 0 idle which is fine. But you also said 98 full. It should be 100 full. Simply if you don't adjust your throttle channel correctly you will have deadband and never reach full throttle. The KK2 board simply will not see the same input you are giving. By using throttle curves and trims you are attempting to mask a setup issue.

Your trims are ok, I don't follow? All of your trims on the transmitter should be centered. If you have had to add trim during flight something is wrong.

Forgot to add the stick scaling menu is where you should see the 90 value for throttle. But from what you have said this probably isn't your issue.
 
#20
My trims are ok in the sense that they're all 0 in the receiver test when the sticks are not touched, and 100, or very close to 100 when moved to the edges. Effectively, a throttle throw of 0-98 is identical to a throttle scaling of 98. Losing 2% over the entire band does not account for me having to provide an extra 10% throttle to get it to hover.

And yes, I saw the 90 (which is default) in the stick scaling menu.

My frame is quite small, and the propellers move inside the frame. I wonder if my problems would be aerodynamic, that I generate less lift because the some of it gets basically blown into the frame...