• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Impossible to bind Vortex 150 with Taranis X9D Plus

#1
Hi Guys,
I am very frustrated. I tried almost the solutions possible but is not possible to bind my brand new Vortex 150 with Taranis X9 Plus. I explain all test I did:
1) The model comes with receiver mode auto in OSD I'll saw continuously changing mode but without find the Taranis;
2) Tried to change manually the mode in SBUS or CPPM but nothing
3) Upgraded my Taranis firmware to version 2.2 EU LUA

In essence what happen. The RX is a FrSKY XM+. So the procedure is: I push the small button in the XM+ plug the battery wait until the beeps than release the button, put BIND in Taranis hear the beeps, the vortex comes with the back LED lights green flashings, than solid green than solid red. The XM+ still solid red and green from the beginning. In receiver mode AUTO looking on OSD I see cycling search between spectrum, cppm, sbus in a sort of loop and nothing else happen.

Any idea how to fix it please?
Thanks