• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

KingKong Smart 100 w/CleanFlight and SF-800 using Jumper T8SG. Please Help

#1
Let me start by saying I'm really ignorant about what I'm trying to do here. I've flown toy drones and my XK380 (which is still kind of a toy drone), and I wanted to go a step deeper so I bought a KingKong 100 and a Jumper T8SG transmitter to fly it with. Probably a mistake. I'm trying to get this thing going. I've learned a lot through videos reading posts, but I'm at a loss. I can't get my motors to respond to the controller. I flashed the drone to ver. 2.0.5 thru Cleanflight. In CleanFlight/configuration I changed the motor type to brushed. Via CleanFlight/motors I can spin the motors up so I'm thinking that part is OK. From Cleanflight/setup I calibrated the accelerometer. I can even see the meters in CleanFlight change when I move stick position on the T8SG so I guessing the transmitter and receiver are "talking". I saw a post that said something about setting the upper and lower throttle limits to 2000 and 1000 accordingly or else CleanFlight won't arm, or something like that. I think I made that change on the transmitter correctly but still no go. I'm thinking that getting the drone to Arm is where my problem lies. I would LOVE to have a private chat or email or whatever you guys call it with someone who wouldn't mind answering some dumb drone questions from an old guy. That way I'm not boring all the experts with my ignorance. I'm sure can get going with this if I can get just a little help to get me going. Thanks
 

ComikzInk

Soft and Foofy
#3
+1 For video choice

That video is probably one of the best ones out there for arming issues. For me at least all my arming issues are down to my throttle being too high.

Most flight controllers won't arm unless your throttle is below a threshold value. Any higher and it refuses to prevent your quad flying away as soon as it's armed. That value is named Min_Check and by default I believe it's around 1100 although I think it's been changed a few times. If your controller is sending anything above Min_Check on the throttle it will refuse to arm.

The video ElectriSean suggested covers this at 8:03 and gives you tips to check what yours is and how to adjust it or work around it. I'd recommend watching the whole thing though as there are many great tips in it that helped me understand my quads a little better.

Good luck and happy flying :)
Lia~
 
#4
Thanks for the responses. I apologize for my late response. I've been with family stuff. It does sound like my problem is that my throttle value is not getting low enough to allow the drone to arm. I can't seem to get it to set below 1000. I think it has to be a setting on the controller and not a setting in Beta Flight. I'll mess with it some more and let you know. Thanks.
 

ComikzInk

Soft and Foofy
#5
Thanks for the responses. I apologize for my late response. I've been with family stuff. It does sound like my problem is that my throttle value is not getting low enough to allow the drone to arm. I can't seem to get it to set below 1000. I think it has to be a setting on the controller and not a setting in Beta Flight. I'll mess with it some more and let you know. Thanks.
No worries :)

Might be worth sub-trimming the throttle if you've hit a limit in Cleanflight. What ranges are you getting out of the controller to the receivver at the moment both min and max?
 

ElectriSean

Eternal Student
Mentor
#6
The adjustment is made in your transmitter, called servo travel or channel endpoints. If your Tx can't adjust far enough, there is the rxrange command in Betaflight, demonstrated here with terrible music:

 
#7
Thanks for the responses. ComikzInk, the min and max values I was getting on the throttle was 1108 and 1518. I used the CLI to run the RXRANGE command per the video as suggested by ElectriSean. The values do jump back and forth a bit, but the throttle min value is now between 999-1000 and the max varies between 2000-2001. That should get my throttle down to a value where it will arm the drone, correct? If so I still can't spin the motors using the transmitter. In BetaFlight I can see the values change when I move the control sticks for pitch, roll, yaw, and throttle. I can spin up the motors via the sliders in BetaFlight using my computer mouse, but the drone won't arm. The Jumper T8SG does have a failsafe of it's own to where the throttle has to moved to the down position before it will function. That's working. Is there a special position I'm unaware of that I have to move the sticks to to arm the drone? I have tried both sticks down and in and both sticks down and out. Any other ideas? Thank You
 

ElectriSean

Eternal Student
Mentor
#8
You should set up switch arming, after setting the endpoints on the pitch roll and yaw channels. Stick arming is probably not working because CF is not seeing the correct values on yaw.

 
#9
It has been a huge learning curve, but thanks to your responses and a lot of internet time I finally got it working! After doing as you instructed I got it to work as it should...but one time.Then when I tried it again while still hooked up thru CleanFlight it went into failsafe mode and I could not get it to out of failsafe mode no matter what I did. I decided to start from scratch and reflashed or updated firmware the T8SG TX and on the flight controller. After setting the TX back up it would arm, but the motors would still spin as soon as I plugged in the battery. After more research I read to set the flight controller via CLI to "motor_pwm_rate to 1000". I did it, but the motors still spun up. I found in the Config section of Clean Flight where I could set throttle values. I set them as follows: Min Throttle=1000, Max Throttle=2000, Min Command=1000. With those settings it all seems to work fine. Does that look OK to you? Do you have any suggestions on what I should do differently or for testing the failsafe? Thanks for the help!
 

ComikzInk

Soft and Foofy
#10
The curve is a bit steep, lots to take in at once just to get a quad airborne. Glad to hear you've got it figured out though.
Your settings seem fine to me, it's mostly preference and fine tuning after you get it working anyway :)