• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Motor on strike

#1
howdy!

im having a motor that just stops after a while of consistent throttle, any one had this problem so far?

when in cleanflight or blhelisuite, i can test the motors, set a low throttle and all motors spin happily ever after :p
but! if i set any throttle value on the transmitter (usb disconnected):
- some stutter on the first 1-3 ticks
- and once they all spin, theres one consistent motor that just suddenly stops
- this remains until i increase or decrease the throttle by any value, and after a few seconds it stops again

and i cant seem to be able to reproduce it when trying with yaw/pitch/roll, but that might also be because its rather difficult holding one exact value for a longer period of time

ps: i tried increasing the ppm min throttle to 1068 in blhelisuite, but it didnt seem to have an effect (max is 1980)

this might also be helpful:
BLHeliSuiteESC overview_160801_1.png
and its motor 4 that is having the issue
 
Last edited:
#2
so far ive tested a variety of ppm min throttle values, up until 1148
the higher the value goes, the longer it seems to take until the motor/s stop while the throttle is on
and it only seems to occur on the both reversed motors (1+4)
only thing that is consistent across all motors (but more common on 1+4) is the occasional stuttering at a low throttle value
 

LitterBug

Troll Spammer
#3
What do you have min_throttle, max_throttle, and min_command set to in cleanflight/betaflight configurator? Generally speaking you set min_command to 1000, Max_throttle to 2000 and then calibrate the ESC endpoints in the motors tab. After calibrating Endpoints, you set min_throttle to adjust Idle speed when armed. You should not change PWM endpoints in BLHelisuite after doing the ESC Calibration. If one ESC has a slightly different clock speed, the min and max PWM will get set to the appropriate different endpoints during the calibration step. Manually setting them all the same can cause the exact scenario you are describing.

Cheers!
LitterBug
 
#4
in cleanflight its;
min - 1000
max - 2000
command - 1005

after setting above values i did the auto-calibration in blhelisuite, where it set the ppm max of 2 ESC's (1+2) one tick higher (1986 i think it is/was)

since it was already showing the same symptoms at this point and it also said "not in sync with master" when connecting with blhelisuite
i started adjusting the values as mentioned before, as well as getting the values equal (mainly to get rid of the sync message)

how else should/would i approach the issue after the auto-calibration?
 
Last edited:

Craftydan

Hostage Taker of Quads
Moderator
Mentor
#5
Min_Command should NEVER be more than Min_Throttle.


Min_Command is the "off" command sent to each ESC. This is what they hear when they aren't armed.

Min_Throttle is the minimum "On" command. When armed and the motors are spinning (airmode or motor_stop is disabled) the ESCs will not receive ANYTHING LESS.



Set Min_Command to 1000 and leave it there.

Temporarily set min_throttle to 1000. In cleanflight's motor tab, check the "I understand" button (because your props are off, right?!?) and adjust up all the motors until all four are spinning smoothly. find the lowest master setting that will do this. If any of them are jittering or stuttering, you're still too low.

Take that number, add 10, and plug that in for the final min_throttle value.

After that, arm and spin up the motors and the control board will never drive a motor off due to corrections from control loops.
 
#6
thank you dan! they all run smoothly now! :D
guess that was a useless guide i followed then :p

only thing is that they constantly spin when disarmed now, even with the throttle at its lowest position (1000)
how do i get around that?

and do i need to recalibrate after adjusting min throttle and command? or will that just mess every thing up again

ps: ofc props are always off indoors :p and the transmitter antenna is always attached
 

Craftydan

Hostage Taker of Quads
Moderator
Mentor
#7
Yeah, you've calibrated them too low, so a recal might be in order . . . or you can lower min_command even lower, but I'd hesitate to do that.

Typically 1000 is the bottom (or below the bottom) so it works for "off". Recalibrating will set it back to that. lowering min_command is a fair workaround, just don't forget you've done that -- reset the settings in a new flash and you might be in for a rude awakening :eek:
 
#8
sweet! cheers dan!

one (hopefully) last question tho: when i have the throttle off, pitch/roll/yaw wont respond, is there a way around that?
 

Craftydan

Hostage Taker of Quads
Moderator
Mentor
#9
Not sure I understand the question.... So with the throttle off, (I'm assuming you're still armed and motor_stop is off so the motors are spinning at idle), the props don't change speed with control?

Feature, not a bug. You want the props to be unresponsive at 0 throttle on the ground or it will be unruly at takeoff and landing. When testing my quads prior to maiden, I usually have to bump the throttle up to 15-20% to get the directional motions to respond. "Light on the skids" is the typical way I describe how much throttle I have to give it before the directional controls behave as expected.

You may still want control while falling, however, and that's where airmode comes in. In airmode, at 0 or low throttle, full control down to minthrottle is available to the controller (including responding to your wishes). You can turn this on/off in the mode settings by assigning it to a range of one of your aux switches.

Be advised, it is airmode, not land mode. You will want to have this mode off while taking off and landing, so map it to a switch that's easy to get to.