• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Motors out of sync

#1
Hey guys…

I have built a wooden H-Quad and this is my first build.
I’m just building it to practice how to fly quads before I build/buy expensive ones.

I’m using following specs:
- Flip32,
- SimonK 30A ESC,
- 2200mAh 25c Lipo.
- Props 10x4.5" 1045L/R
- A2212 KV1000 Brushless Motors


When I increase the throttle to 25%-30% I see motors are all out of sync.
I connected to CleanFlight and clicked the “Motor tab” to see how the motors are doing.

I have calibrated the ESC as it should be in CleanFlight.

See the attached video.

Could please someone help me with this issue.


[video]https://youtu.be/_jJK1Lz71UU[/video]
 

cranialrectosis

Faster than a speeding face plant!
Mentor
#2
Wow that lower right motor!

Does that motor or the ESC get hot? If so, check the solder joints and check the motor screws to ensure you are not penetrating the boom up into the motor coils in the motor.

Do all the motors start at the same time? In Cleanflight when you throttle up each motor do they all start at the same number?
 
#3
Have you tried to fly it?

I have a 235 quad with 2204 motors and am using a Naze32 with clean flight. If I go really slow on the throttle none of the motors spool up together. I've tried calibrating in clean flight and the old school way by hooking escs directly to the reciever. I have never gotten them to spool up together. But once I go past a certain point on the throttle, they all seem to work in sync and it flys well. Have you tried spooling them up without the props? Do they start to sync up the higher you go with the throttle? Check you connections like the other post said and then put some tape on the shafts so you can visualize the spin minus the props and give that a try. If you get past your estimated take off throttle setting and they look sync 'd it should fly. Best way to find out once you are ready to fly it is to raise the throttle extremely slow. If it starts to spin on the ground you definitely have a problem.

With all that said, based on the video, you might have an ESC/motor issue or a board issue. I had a bad board once that wouldn't spin one of the motors correctly. Once I replaced the board it worked fine. Coincidentally it was an H quad like yours. It was also my first build.