• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Naze 32 - No Throttle/Roll/Pitch/Yaw Inputs

#1
I've watched the FT Naze 32 board setup video (for the 10th time) and wanted to ask for assistance. I'm trying to setup my new Naze Acro board on my quadcopter. I went through all the steps in the video but cannot get my throttle, roll, pitch and yaw signals from my receiver to register with the board. I have successfully accomplished the following: flashed Naze V10 firmware, installed chip drivers, calibrated accelerometers, tested each motor for correct positioning and direction. What is perplexing is that my Aux 1 and Aux 2 channels work correctly are are being recognized by the cleanflight software. Again however, TAER just shows frozen at 1500 on the receiver tab of the configurator and will not respond to receiver inputs. I have tested the receiver independently using simple servos and all channels respond as they should. I am powering the receiver via an external BEC as my ESCs do not come equipped with them. It seems that I have tried every possible combination from the configuration tab of the cleanflight software but again, to no avail. Why am I able to get accurate readings from Aux 1 and 2 but not from the other 4 channels? Also, I checked the latest firmware for my Frsky D8R-II Plus receiver and am assured that it is loaded on the receiver. Also have checked all soldering points to the board as well as tried various cables to try to isolate a fault.

Any help would be appreciated.
 
#2
Is it a revision 6 naze32? Last I checked, the naze32 v10 firmware does not work correctly with the rev 6. Requires either the travis build or betaflight firmware loaded locally from your pc.

An easy way to confirm whether you have this issue with the firmware is to see if the 3d model in cleanflight responds when you physically move your naze.

How is your rx wired to your naze? I'd recommend connecting with sbus. But if your naze is not a rev 6, it will require an inverter. But no matter which rev naze you have, the naze should supply the correct voltage to power your rx. No bec needed for the rx. You should use the bec to power the naze and the naze will power the rx.

Before I go much further, let us know what rev naze32 you have and verify the 3d model in cleanflight responds to physical movements made to the naze.
 
Last edited:

cranialrectosis

Faster than a speeding faceplant!
Mentor
#3
Sounds like a receiver problem or a connection problem.

I concur with MototechRyan. We need more detail, maybe a picture showing the wiring. Using a BEC to power a receiver is very odd. How are you powering the Naze?
 
#4
cranialrectosis and MotoTechRyan,

Thanks for all the good advice. It seems I have solved the problem with your help and want to add my solution for the archive. I have a Revision 5 Acro board and it appears flashing the board with version 9 (previously had version 10) of the software was the solution. Initially I wasn't concerned as all versions showed (stable) next to the description. Regardless, the board now has version 9 and all is well. I did however test the 3d onscreen model while version 10 of the software was loaded and it responded normally. I have tried various ways to power the receiver, both by plugging the BEC into an unused port of the receiver as well as into the 5th motor output of the board. Both methods produce good results and I'm glad to know that wasn't the problem.

Thanks again for your help. I guess sometimes too many options in a system can lead us down rabbit holes from time to time.