• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Naze32 Acro/windows 10 nightmare HELP!!!!!!!

Sharky

Junior Member
#1
So here's the deal guys an believe me when I tell you that I've spent countless days trying to figure this out on my own.
Problem: For whatever reason I get a Failed to open serial port whenever I try to load the firmware in cleanflight. I haven't been able to get ti to load or recognize the port no matter what I try (and believe me when I tell you that I have looked everywhere). I am NOT a quitter and could really use help getting this thing to talk to my laptop. Any help you guy's could offer would be most appreciated. Thanks, Randy (a noobie to this tricopter world)
 

makattack

Winter is coming
Moderator
Mentor
#3
Also, not all USB cables are created equal. You might try different ones you have until you can flash/connect.
 

PHugger

Church Meal Expert
#4
And one more thing....
You load the firmware BEFORE you connect Cleanflight to the board.
After the firmware loads you can connect and configure.


Best regards,
PCH
 

Sharky

Junior Member
#5
Wow, thanks guys your unbelievable I tried everything except other cables as I just pulled the cable out of a bag and has never been used I will give a couple of other cables a try as well and see if that's the problem as I have already spent days trying to trouble shoot this, who knows I just assumed that it was not the cable because the light on the board lit up with blue n green then a steady green I figured that it was connected but hey, stranger things have happened, right? I'll give ya a heads up if it happens to be that easy. Thanks again.
 

Sharky

Junior Member
#6
If that don't beat all. I tried 4 more cables that I had laying around the house an it ended up being the cable after all! I don't know if it makes a difference but the one that worked had a black tab of sorts inside the larger of the 2 ends. The other 3 had white tabs sounds weird huh? I did some research on it and it does make a difference because they have designations like 1.1 1.2 3.0 etc. Who da thunk, eh? Live n keep on learning. You would think after being on the planet for 60 years that I would have known. Anyway I would like to thank all of you who helped me out (YOU ROCK!) I hope any other problems I have are as easy to solve. Randy
 

eroeder

Junior Member
#7
Also, not all USB cables are created equal. You might try different ones you have until you can flash/connect.
For me I was going nuts with my Mac and El Capitan, bootcamp, and even Windows 10 laptop, Apparently the cable I was using was a CHARGE micro USB cable and not a CHARGE/SYNC micro USB cable. Turns out, not all cables are the same...

new cable, and it works like a champ.

Apparently, same difference exist for iPhone cables and others. Some are charge only, while others can charge and sync. Who knew???
 
Last edited:

zann68

New member
#8
Amen!!!

Also, not all USB cables are created equal. You might try different ones you have until you can flash/connect.

I realize this is an old thread......but Yes I found this out myself. Very frustrated about why my replacement board would not connect. I even changed USB cables thinking it could be the cable. I bought a headset that came with a short cable and the I had to do a firmware update on the headset. No issues. I decided to try this little short cable, it worked.....4 cables and a no go. So with that said try all your cables and tag that one that works......they are not all made the same.
 
#9
x10 on the cable. had the same week-long frustration until I read the cables can be different (had tried 5 til I found one)

also, verify in device manager, after you plugin your naze, that a new com port gets created, silicon labs COM#