• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Naze32 Arming Problems

Shihido

Junior Member
#1
I have a custom build Tricopter (using the RCexplorer frame; and most of the recommended build components)

Its set up with the Naze32 and Lemon featherlite DSM2 transmitter. I've programmed one of the aux switches for arming/disarming; and a separate switch to toggle horizon mode.

The maiden flight was fine and I didn't have any problems at all during the half an hour.

However subsequent flights; I'm having some issues with arming the tricopter;

I would power on the tricopter and my Tx, and after the Naze32 calibrates, i am able to arm it. I can throttle on into a hover, but subsequently i would lose control of the throttle, and can't throttle up or down; but the props are still spinning under power. I would disarm and the props would stop. After this; i cannot re-arm the tricopter again. Or sometimes it would arm itself but have the same issue.

I've connected to CleanFlight and found that the board would register that the Arming switch is in the on position but the board won't still arm.

What do you guys think i should do?

One possible cause that I can think of is that the board is programmed using Baseflight (but only because i can't seem to be able to do it on Cleanflight) but the aux switch is configured using Cleanflight (also because i can't seem to be able to do it in Baseflight).

Untitled.png
 
#2
firmware is not the same between baseflight and cleanflight, so that is probably part of the reason you are having issues. Which firmware do you have flashed to the board? I am assuming the baseflight version. I would suggest flashing the board to cleanflight and setting everything back up again, and see if your issue goes away.
 
#3
I was having the same problem the other night. Using a Orange DSMx sat RX hooked up using serial RX. The switch would register and show it was within the arm "band" of the mode. But would not arm. I did two things, yeah I know. One. I started from scratch since it was a new build anyway and re-flashed it with the 1.7.2?? The most current verified Naze32 software. Number two was when setting up I made sure that my Throttle at the low read 1000, and at the high read 2000 and that in the middle read 1500 on cleanflight. Went back and setup the arm with Aux1 and it worked. I have tried it both plugged in and on battery power alone both worked like it was supposed to. Not 100% sure what fixed it. While searching on Google I found a couple other threads with the same problem. Not very many. Good luck.
 

makattack

Winter is coming
Moderator
Mentor
#4
Yah, using a mix of cleanflight-configurator and baseflight sounds like a recipe for undefined behavior, but I'm surprised you can even do it.

Interestingly, the symptoms sort of sounds like you've hit failsafe at some point. I know when testing failsafe, if I trigger it, the board will not rearm without a reboot.
 

Shihido

Junior Member
#5
Thanks everyone for the advice. Reprogrammed the Naze32 using only Cleanflight and seems to be working as its supposed to during the hour long test flight.