• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Throttle problems with Jumper T12

#1
I received my Jumper T12 this morning and set about loading two of my models. All went quite well until I started trying to edit the throttle settings. At first the throttle was running as soon as the model was bound. I was trying to edit the mix setting to reduce the throttle to zero when the gimbal was at zero but then the throttle stopped working altogether. Now, as soon as any model is bound, I get a Throttle Warning, but the throttle is not set to any gimbal, switch or Aux - at least not that I can find.

I decided to update the firmware to v2.2.3 to see if this solved the issue but it didn't and now my screen display is inverted.

I couldn't find a solution on the OpenTX forums, or anywhere else.

Can anyone help?
thanks
Moira
 

FDS

Well-known member
#2
If you can get screen shots of each of the set up screens that will help. Also what models are you binding to? Which protocol you have, especially the latency on DSMX/DSM2 can have an effect on that.
It’s not a firmware issue, somewhere you have a setting off.
I found there were too many setting options on my Jumper to start with! There is not enough set up info on YT either, especially for DSMX.
It took me 3 weeks to sort out my Sport Cub S on the Jumper.
 

FDS

Well-known member
#4
Which planes/receiver are you trying to bind to?
I did all my programming off the TX screens, as I don’t have a PC, so can’t tell anything from your screenshots but there are lots of cleverer people than me on here who might be able to help with what’s there.
 
#6
Which planes/receiver are you trying to bind to?
I did all my programming off the TX screens, as I don’t have a PC, so can’t tell anything from your screenshots but there are lots of cleverer people than me on here who might be able to help with what’s there.
This is independent of the plane I am trying to edit. It happens with every plane so it is a global issue.
 

FDS

Well-known member
#7
Right. That’s interesting. It must be a global setting, I cant help with that, sorry!
Mine worked fine on basic stuff out the box, so I left it alone.
 

pressalltheknobs

Posted a thousand or more times
#8
Where did you get the version of "OpenTX 2.2.3" from? Jumper does not actually use "OpenTX" but their own version called JumperTX
https://www.jumper.xyz/jumpertx
which is based on OpenTX.

Assuming that has nothing to do with your problem, a common reason for throttle confusion in OpenTX is because the configured Mode does not agree with the way the sticks are setup. I don't have a Jumper (except one of those knitted things) but if you do a factory reset on a Taranis it will set the Mode to 1 and if your sticks are set up for Mode 2, you will immediately start getting throttle warnings because the TX thinks the right stick is the throttle and it is auto centered. The fix is to go into the radio settings and set the Mode to the one that agrees with your sticks...generally Mode 2. While in there you should also set the default channel order (used for new models) I generally recommend using AETR on a FrSky TX partly because that is what the multiprotocol module assumes. Probably its the same for Jumper.