• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Troubles flashing Cleanflight on Naze32

Foxty

New member
#1
Hi guys !
I'm new to FPV and bought a RTF Kit from Eachine 1 month ago.
Now that I know how to properly fly with it I wanted to flash it with Cleanflight just to modify PIDs/Rate/etc.
So I Naze32 FC from Cleanflight and everything went well.
I've setup transmitter settings so Cleanflight recognize my Eachine I6.
But my motors won't spin !

In the "configuration" tab I don't know which option to choose
-Oneshot
-DSHot
-Brushed
-PWM
-etc...
I tried them all and none of them seems to be working.
In the "motor" tab I can see that the informations are received to the quad (the jauges are moving with my sticks), but it seems the ESC don't understand what my FC told him (Yeaj I don't know how to say differently).

Anyone can help me ?
Thanks and sorry for my bad english, it's not my native language :)
 

ElectriSean

Eternal Student
Mentor
#2
Which kit are you working with? At the least, PWM should work, but Oneshot, Multishot, DShot etc may work. Have you set up switch arming in the modes tab? Have you set up your transmitter endpoints?
 

Foxty

New member
#3
Hey,
Thanks ! The PWM option worked !!!
But now my ESC are not calibrated and every time i try to calibrate them it loops with beeps...
Strange.
 

PsyBorg

Wake up! Time to fly!
Mentor
#4
You are taking too long to drop the throttle and they are going into programming mode.

Props off.. connect to the gui. Enable motors. Confirm props are off.. Raise the main slider to max throttle. Plug in flight battery for the quad. As soon as tones start to play drop main slider to zero and the esc's "Should" reboot and be calibrated thus starting at the same time and rising in the same speeds as the main slider is manipulated. Unplug the battery disconnect from the computer. Complete the setup procedure.