• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

Very high TRAVEL ADJ on Spektrum DX6i with Cleanflight 1.9.0 on Naze32

#1
I have this "issue" where I have to push my travel adjustment on my sticks almost to max (~120% out of max 125%) to get them up to 2000 and down to 1000. Am I doing something wrong? Should I be tweaking this somewhere else? It flies well even without these settings, in theory, but I've never been able to push out of the angle part of horizon mode before. I haven't been able to do flips, so I figured it was because it didn't get all the way to 2000. I haven't had a chance to test this hypothesis, but I wanted to check with you guys first. I have this for all the primary channels

Is it unexpected to have such a high travel adjustment?
Is it detrimental in any way?
Is there somewhere else I could change it?
 

narcolepticltd

I unbuild stuff regularly
#2
This is actually standard for a spektrum radio, you're doing it exactly right :)

Where you'll notice the difference is when you get into acro stuff and start doing flips/rolls/etc, as with the end points set correctly... it goes to 11 ;)

Volume_Knob_Logo_500x500.jpg
 
#3
That's good to know =)
I tried to get as close to 1000 and 2000 as I could. Are there advantages or disadvantages to over- or under-shooting? E.g. ending up at 1999 or 2001 and 999 and 1001. Should I prefer to be "inside" the range (1001 and 1999) or "outside" (999 and 2001) or a mix?
 

narcolepticltd

I unbuild stuff regularly
#4
That's good to know =)
I tried to get as close to 1000 and 2000 as I could. Are there advantages or disadvantages to over- or under-shooting? E.g. ending up at 1999 or 2001 and 999 and 1001. Should I prefer to be "inside" the range (1001 and 1999) or "outside" (999 and 2001) or a mix?
naah you're good. the only outside you need to be in right now is meatspace, flying it :)
 
#6
10 propellers lost. No significant difference in feel. I did manage to get it to tip over sufficiently to enter into a flip from horizon mode, so I guess it worked. That said, I didn't manage to complete a whole flip, and I lost 3 propellers in the process...
 

NHS77

Senior Member
#7
Do you have any dual rates dialed in on your radio? that could prevent you from going all around in a flip... if not perhaps you have to up your roll/pitch rates in Cleanflight. That is if your machine is not underpowered or anything...

Otherwise in Horizon I just go full stick and it flips fine... you have to hold it though until it passes 180°....
 

narcolepticltd

I unbuild stuff regularly
#8
Pungbjoern, go ahead and post your set up (frame, motor/prop, battery, etc) here as well as your current PID controller r/p/y rates/gains and we'll see if we can help a little on the tune department.

Breaking props means you're making progress :)
 
#9
Do you have any dual rates dialed in on your radio? that could prevent you from going all around in a flip... if not perhaps you have to up your roll/pitch rates in Cleanflight. That is if your machine is not underpowered or anything...

Otherwise in Horizon I just go full stick and it flips fine... you have to hold it though until it passes 180°....
I'm actually calling this a success. The fact that it didn't go all the way around is attributable to me not knowing how to flip this frame. I can do it perfectly fine on a Blade Nano QX. Previously it would slam to a halt at 90° and fall down. That I got it much further than that is a success in my book. I've been watching some videos. As soon as I get a new frame (broke two arms on my second outing today) I'll nail it. Apparently I haven't been giving it enough throttle...
 
#10
Pungbjoern, go ahead and post your set up (frame, motor/prop, battery, etc) here as well as your current PID controller r/p/y rates/gains and we'll see if we can help a little on the tune department.

Breaking props means you're making progress :)
Here's my setup:
Frame: HobbyKing 250 color (I love this thing!)
Motor/ESC: 2206 Baby Beast Motor and 12A Afro ESC
Propellers: Gemfan or Diatone 5030

I've removed some stuff like LED and GPS/NAV things from this to make it a bit more readable.
Code:
# version
# Cleanflight/NAZE 1.9.0 May 31 2015 / 13:17:47 (98f7549)
# dump master

# mixer
mixer QUADX


# feature
feature -RX_PPM
feature -VBAT
feature -INFLIGHT_ACC_CAL
feature -RX_SERIAL
feature -MOTOR_STOP
feature -SERVO_TILT
feature -SOFTSERIAL
feature -GPS
feature -FAILSAFE
feature -SONAR
feature -TELEMETRY
feature -CURRENT_METER
feature -3D
feature -RX_PARALLEL_PWM
feature -RX_MSP
feature -RSSI_ADC
feature -LED_STRIP
feature -DISPLAY
feature -ONESHOT125
feature -BLACKBOX
feature RX_PPM
feature VBAT
feature MOTOR_STOP
feature CURRENT_METER


# map
map AETR1234


# serial
serial 0 1 9600 57600 0 115200
serial 1 0 9600 57600 0 115200


set looptime = 3500
set emf_avoidance = 0
set mid_rc = 1500
set min_check = 1100
set max_check = 1900
set rssi_channel = 0
set rssi_scale = 30
set rssi_ppm_invert = 0
set input_filtering_mode = 0
set min_throttle = 1150
set max_throttle = 1850
set min_command = 1000
set servo_center_pulse = 1500
set 3d_deadband_low = 1406
set 3d_deadband_high = 1514
set 3d_neutral = 1460
set 3d_deadband_throttle = 50
set motor_pwm_rate = 400
set servo_pwm_rate = 50
set retarded_arm = 0
set disarm_kill_switch = 1
set auto_disarm_delay = 5
set small_angle = 25
set flaps_speed = 0
set fixedwing_althold_dir = 1
set reboot_character = 82
set serialrx_provider = 0
set spektrum_sat_bind = 0
set telemetry_switch = 0
set telemetry_inversion = 0
set hott_alarm_sound_interval = 5
set battery_capacity = 0
set vbat_scale = 110
set vbat_max_cell_voltage = 43
set vbat_min_cell_voltage = 33
set vbat_warning_cell_voltage = 35
set current_meter_scale = 400
set current_meter_offset = 0
set multiwii_current_meter_output = 0
set current_meter_type = 1
set align_gyro = 0
set align_acc = 0
set align_mag = 0
set align_board_roll = 0
set align_board_pitch = 0
set align_board_yaw = 0
set max_angle_inclination = 500
set gyro_lpf = 42
set moron_threshold = 32
set gyro_cmpf_factor = 600
set gyro_cmpfm_factor = 250
set yaw_control_direction = 1
set pid_at_min_throttle = 1
set yaw_direction = 1
set yaw_jump_prevention_limit = 200
set tri_unarmed_servo = 1
set servo_lowpass_freq = 400
set servo_lowpass_enable = 0
set failsafe_delay = 10
set failsafe_off_delay = 200
set failsafe_throttle = 1000
set rx_min_usec = 985
set rx_max_usec = 2115
set acc_hardware = 0
set mag_hardware = 0
set blackbox_rate_num = 1
set blackbox_rate_denom = 1
set blackbox_device = 0

# dump profile

# profile
profile 2

# aux
aux 0 2 1 1825 2025
aux 1 12 0 1850 1975


# adjrange
adjrange 0 0 0 900 900 0 0
adjrange 1 0 0 900 900 0 0
adjrange 2 0 0 900 900 0 0
adjrange 3 0 0 900 900 0 0
adjrange 4 0 0 900 900 0 0
adjrange 5 0 0 900 900 0 0
adjrange 6 0 0 900 900 0 0
adjrange 7 0 0 900 900 0 0
adjrange 8 0 0 900 900 0 0
adjrange 9 0 0 900 900 0 0
adjrange 10 0 0 900 900 0 0
adjrange 11 0 0 900 900 0 0


set alt_hold_deadband = 40
set alt_hold_fast_change = 1
set deadband = 0
set yaw_deadband = 0
set throttle_correction_value = 0
set throttle_correction_angle = 800
set default_rate_profile = 2
set gimbal_flags = 1
set acc_lpf_factor = 4
set accxy_deadband = 40
set accz_deadband = 40
set accz_lpf_cutoff =  5.000
set acc_unarmedcal = 1
set acc_trim_pitch = 0
set acc_trim_roll = 0
set baro_tab_size = 21
set baro_noise_lpf =  0.600
set baro_cf_vel =  0.985
set baro_cf_alt =  0.965
set mag_declination = 0
set pid_controller = 3
set p_pitch = 40
set i_pitch = 30
set d_pitch = 23
set p_roll = 40
set i_roll = 30
set d_roll = 23
set p_yaw = 85
set i_yaw = 45
set d_yaw = 0
set p_pitchf =  2.500
set i_pitchf =  0.600
set d_pitchf =  0.060
set p_rollf =  2.500
set i_rollf =  0.600
set d_rollf =  0.060
set p_yawf =  8.000
set i_yawf =  0.500
set d_yawf =  0.050
set level_horizon =  3.000
set level_angle =  5.000
set sensitivity_horizon = 75
set p_alt = 50
set i_alt = 0
set d_alt = 0
set p_level = 90
set i_level = 10
set d_level = 100
set p_vel = 120
set i_vel = 45
set d_vel = 1
set yaw_p_limit = 500

# dump rates

# rateprofile
rateprofile 2

set rc_rate = 90
set rc_expo = 65
set rc_yaw_expo = 0
set thr_mid = 50
set thr_expo = 0
set roll_rate = 0
set pitch_rate = 0
set yaw_rate = 15
set tpa_rate = 0
set tpa_breakpoint = 1500
 
Last edited:

narcolepticltd

I unbuild stuff regularly
#13
Interestingly the decimal points on the stuff in the dump are WAY off.
Says: "set i_pitch = 30". Is actually: 0.030
I don't know if this is expected.
View attachment 51902
the way it displays in the GUI compared to the CLI is different. When in doubt and looking at other's PID values, if it's text and looks like it was cut from a dump, just paste that line into the CLI.

I see those photos man that sucks bad about the frame! Right now in your dump the r/p rates are sitting at 0, with the default RC rates at .9 (90%), and this would mean a flip or roll would require a LOT of altitude to complete.

I like the table!
 
#14
the way it displays in the GUI compared to the CLI is different. When in doubt and looking at other's PID values, if it's text and looks like it was cut from a dump, just paste that line into the CLI.

I see those photos man that sucks bad about the frame! Right now in your dump the r/p rates are sitting at 0, with the default RC rates at .9 (90%), and this would mean a flip or roll would require a LOT of altitude to complete.

I like the table!
Regarding the r/p rates, I can't imagine setting them higher. Hell, I'd like them LOWER. I have -15% expo on both roll and pitch, as otherwise I very easy fall over on my side. I set the yaw to 0.7 when I came from base flight and this was so absurdly high that I can't imagine ever setting pitch or roll to anything higher than 0. They're twitchy enough as it is. I suppose I could set it to like 0.5 and then set -50% expo or something.
 

narcolepticltd

I unbuild stuff regularly
#15
Regarding the r/p rates, I can't imagine setting them higher. Hell, I'd like them LOWER. I have -15% expo on both roll and pitch, as otherwise I very easy fall over on my side. I set the yaw to 0.7 when I came from base flight and this was so absurdly high that I can't imagine ever setting pitch or roll to anything higher than 0. They're twitchy enough as it is. I suppose I could set it to like 0.5 and then set -50% expo or something.
start with the RC rates at 1.0, and use 70% expo in cleanflight (do not use any expo on your transmitter). At that point you can start to inch the r/p/y rates up to taste

rc rates and expo are on the receiver tab, r/p/y rates are on the tuning tab. Sorry to be curt, just trying to get a reply out before I head out the door... check your pm's!