• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Pumpkin drop event

EMAX ESC compatibility with Pixhawk.

kickapuppy

Junior Member
#1
I have been working on a tricopter using the FliteTest power pack. I have gotten to the point of testing the motors on the flight controller and cannot get the EMAX ESCs to initialize. I have made sure the arm button is solid, calibrated the Tx, double checked that the FMU is arming, it is in stabilize mode, I can get the ESCs to initialize on a servo tester, or off the Rx, but on the Pixhawk I get nothing whatsoever.

I did some digging and came across a few threads of people claiming that EMAX ESCs will not work with Pixhawk because the voltage on the servo rail is 3.3v instead of 5 and the ESC draw pulls that down to 2.8v or 2.2v I don't know how accurate that is, but I was hoping somebody on these forums might have found a work around and/or possibly run into it and discovered they were just overlooking something.

Here is some links to other people describing the exact problem I am seeing.

http://diydrones.com/forum/topics/pixhawk-with-emax-blheli-esc-not-working

http://www.multi-rotor.co.uk/index.php?topic=12821.0

https://groups.google.com/forum/#!topic/px4users/UrDdbw4o7ho


EDIT:

After some more tinkering I pulled out my spare MRM 12a BLHeli ESC and tested it with the Pixhawk. Sadly it worked great. The MRM ESC is running BLHeli 13.1 I am not sure about the EMAX ESCs from the power pack because the USB linker won't talk to them.

Kinda bummed I had to buy 5 more ESCs to finish this build, but on the bright side I will have 5 20a ESCs to make scratch builds with!

TLDR; Avoid the EMAX ESCs if you plan to use a Pixhawk.
 
Last edited:

jipp

Senior Member
#3
thanks for the tip. i would of never guessed a ESC would not be compatible with a FC. i wonder what the fix would be. if the ESC could be flashed, i guess maybe a new version of Bheli, or simon.. but from what i understand some of the Emax ESC can not be upgraded?

but i can say the Emax ESC i have work great on a quad. so yeah you may of had to buy more.. at least you have a set now to start another build.. one less thing to buy.. i always try to look at the issues i have in a positive light. not always easy.. but sure makes life easier to get through. LOL

chris.
 

vlaporte

Junior Member
#4
07/04/16

Problem – Pixhawk not initialize ESC
My Pixhawk (firmware 3.3.3) controller will not initialize the ESCs on my home made QUAD.

I setup the Pixhawk origallialy on a HobbyKing Turnigy SK450 Quad with Multistar 20amp sbec and Multistar 2213 – 935kv motors and it worked fine.

Now when I moved the Pixhawk to this new quad (EMAX BLHeli 20amp ESCs and EMAX 2213 935kv motors) the Pix starts up ok but the ESC/motors never give those initial beeps. I have tried resetting the throttle end points 1000 to 2000 in Mission Planner software – no joy.
I have tried to teach the Pixhawk the throttle range (program the ESCs – power up the Pix with throttle in high position ) but no programing beeps from ESC/motor.
I am stumped – why does the PIX not talk to my new ESC/motor combo?
I am planning to move the PIX back to the Turnigy SK450 just to prove that I have not lost my mind.
Kindly help and old man (72).
Thanks,
Vince