Femto F3 Short Circuit Hunt

Hello Everyone,

My Femto F3 on my Gremlin seems to have a tiny short. It powers up okay, arms most of the time, and even begins to spin up the motors. If I spike the throttle, however, it goes back to idle and disarms. I put a multimeter on the power leads and got an 11 on the highest Ohms setting on my screen. Not completely sure what his means, but I think it means I have a short, since testing other points yields a reading upwards of 300. I removed everything from the board and tried to clean up my solder, but still got the same result.

(please ignore the little white wire - it's just there to prop up the FC)

Attached are images of the front/back of the FC.

Does this mean I fried my board? Am I reading my multimeter wrong? Thanks in advance for the help!


  • IMG_2756.JPG
    6.8 MB · Views: 0
  • IMG_2757.JPG
    2.1 MB · Views: 0


Antigravity or bust...
Hi PenguinWings, Did you find the problem? I'm no expert but a short should read 0 (zero) ohms resistance, it sounds more like an intermittent open circuit which is like a cut wire. If a trace or connection is just barely making contact then a little heat can deform the metals breaking the circuit. It's hard to tell from the photos but I would look really close at those exposed copper areas on the back (img2757) for tiny breaks in the traces. It almost looks like a trace could be cut near the top right corner of the processor.


Wake up! Time to fly!
You are only reading the equivalent resistance for the part of the circuit you are probing. A short would be straight up 0 ohms. If a trace were open in that part of the circuit you would read infinite resistance (Open air)

A better guess is with all that goop all over the board and the signs of serious over temperature soldering you have heated one or more of the chips to the point of changing its properties. It is possible to clean that mess up and rewire it to try again in hopes that goop was creating a path to bleed off voltage or change resistances on a path creating an intermittent failure.

I had similar symptoms on a KISS FC and when I replaced mine I passed that to Litterbug who did a major cleaning and revived the chip. It seems grass goop had accumulated somewhere on the FC to create a path that induced weird behavior.

Grab a tooth brush and some isopropol alcohol and clean that off. Then watch this video and try that technique to solder. Do not use any flux or pastes or any of that other unnecessary junk. There is plenty in the solder to do the job properly unless you are for some reason using plumbers solder. If you have other junk electronics use them to practice on to get this down if you can.

Wow, good eye Kpixels! I did slice along there trying to separate what I thought was a bridged solder joint... I won't be doing that again! I went ahead and ordered another board, but I'll give Psyborg's cleaning idea a try under the slim possibility that miraculously it still lives despite my slashing it with an knife. :)

Funny thing: I tested the new board with my multimeter and got the same number. I think its because the multimeter was on the 2000k setting. When I turn it to the 200 setting it shows nothing ('open air'). I guess maybe the silicon or something is barely conductive, but not enough to actually change anything?

Psyborg, thanks for the video! My iron can supposedly go from 150 C to 450 C - is there a particular temperature you recommend? I did have it around 350 C.