• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
#1
Hey everyone, I need some help with my F3 femto flight controller on my gremlin. I first built my gremlin a couple months back and after many flights and crashes it was time for me to replace the f3 femto FC. So I ordered a hole brand new micro power pack that comes with new motors, ESCs, and f3 femto. I first put the board into DFU mode on betaflight and flashed it with new firmware, I then removed the jumper on the boot pads and connected to betaflight to make sure the flight controller responded properly and it did. I then began solder everything together. Checked for shorts and there were no shorts anywhere. When I was done soldering I plugged back into betaflight, everything responded as it should have. Now it was time for me to calibrate the ESCs, I did the calibration process, the little guy sang the way he was supposed to when putting the master slider all the way to the top and bottom of the range. Then I disconnected from betaflight, and disconnected from betaflight. I went back into the motors tab to check rotation of the motors using the master slider. Motors #1, 2, and 4 spun up like they should. But from motor #3 I got nothing. I then proceeded to begin testing for a bad ESC or motor on #3, by swapping ESCs and motors from the working motors to #3. Again I got nothing from #3. The motor and ECS from motor 3 worked on #2 and the working motor on #2 doesn’t spin up now. So I’m not sure if this is a problem with the flight controller or what. I’m not a newbie when it comes to building quads, or the betaflight configurator. I do a good solder job. I’ve been doing it for a couple years now. Any help is greatly appreciated. Thank you!!
 

PsyBorg

Fly Angry
Mentor
#2
When I was flying mine a lot in the early stages that one motor not spinning up upon arming was very common.

All I would do was wiggle pitch and roll a bit before take off and it always woke up.

Later after fine tuning it for flying in ground effect it stopped doing that all together once I raised min throttle over 1060.

Try that and see if that helps.
 
#3
When I was flying mine a lot in the early stages that one motor not spinning up upon arming was very common.

All I would do was wiggle pitch and roll a bit before take off and it always woke up.

Later after fine tuning it for flying in ground effect it stopped doing that all together once I raised min throttle over 1060.

Try that and see if that helps.
Thank you I will definitely try that. I just think it’s odd that motor #3 wouldn’t spin up using the master slider.
 

PsyBorg

Fly Angry
Mentor
#4
I did not catch that til I reread you op. Other things to try is to revert to an earlier version of the spf3 target as well as the earlier gui if you go back fsr enough.

This is one of the reasons I am loath to update mine. Seems like the more they incorporate all these fancy filters the more problems arise in basic set up.