• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Gremlin Noob having trouble arming the motors. Day 4 :(

Frolic

"You are dead, Frolic"
#1
Hi everyone,

I am brand new to multi rotors. I have flown a eachine 010. Built the Gremlin following TJ's video. Here is the current state.

I can get Betaflight to see and flash spracingf3evo one day to figure out how to get into DFU mode, whatever that means. I was also able to get my rx bound to my DX6. two days for that bc I soldered the signal wire one dot over.
I can connect with usb and Betaflight and see the gyro is cool. I can see the rx doing it's thing and have all the channels finally doing things correctly in Betaflight.
I flashed the ESC's with BLHELI and switched directions on 3 of the motors.
I can see they spin right using Betaflight sliders on the motor tab.
What I can't do is get the motors to spin using my tx.
I put an arm on aux 1 to switch A in betaflight

So disconnect the usb power up and the flight controller blinks. Motors beep like it is binding, the bind light on the rx stays solid. Camera works.
Cannot get the tx to do any thing.
Things I have tried making sure the fc is nice and level, tried putting the arm value to 1160 which is a little above my lowest throttle value. last 2 days

I know I am not seeing something obvious but no youtube or anything else I have found on the forums have helped. Can you guys help?

Getting soooo clooooose!
 

PsyBorg

Wake up! Time to fly!
Mentor
#2
What TX are you using? Did you assign the switch you chose in betaflight in the radio to work on that particular aux channel?
 

ElectriSean

Eternal Student
Mentor
#3
What do you mean by arm value? min_throttle? This should be set as low as possible, 10 or so above what your motors all start to spin consistently. min_check is the value that the throttle must be below to arm the motors. By default, it is 1100. If you haven't set your endpoints to 1000-2000 ( you say that your lowest throttle value is around 1160) it will never arm.
 
#4
I bought the Emaxx baby hawk - Gremlin with a plastic body and had the same issue....

1) Do your motors spin when you test them through beta flight?
2) did you set your max and min throttle settings in beta flight?? - After doing this did you re-calibrate the ESC's?

This step is important... You should be able to see what the maximum throttle and minimum throttle is through cleanflight. by default it is set to 1000 and 2000... Min had to be changed to 1100 and 1900...

Basically if the ESC's don't see a minimum throttle they will not arm...
3) is you throttle trim at a minimum value?
 

Frolic

"You are dead, Frolic"
#6
I can get the motors to spin with beta flight.
I did not set the min max values. The values I read when moving the throttle are 1164-1895. How do I set the values?
 
#7
If that is with your throttle trim at min,
set your low end point at 1170 or something
and set your arming point at 1200 or something.
 
#8
I believe on the left select configuration,
scroll to ESC/Motor features

Make sure to recalibrate ESC's after this..
 
Last edited:

ElectriSean

Eternal Student
Mentor
#9
You set your endpoints in your transmitter, servo travel. Throttle, roll, pitch and yaw should all show 1000-2000 in the receiver tab, otherwise you are losing resolution. The centers should be set at 1500 using the subtrim setting in your transmitter (not really important for throttle, but very important for the other 3).
 

Frolic

"You are dead, Frolic"
#10
Ok,

Step 1. Edit my channel throws to be 1000-2000. With Trims centered. Exactly? Or +- 5? Assuming in Betaflight, I can youtube that.
Step 2. Set my endpoint. What should be lower, the endpoint or the throw? How close? 5 or 25 or ? I think the throw.
Step 3. Recalibrate ESC's. In BLHELI or when binding like a Power Pack C?
Step 4. Finish moving my daughter from college before any other steps. Thanks guys for helping. Does it seem to you to be a simple setting?
 
#11
I had trouble finding it...

In the flite test videos they make the transmitter go from 1000 - 2000...

My JR DSMX will not go to quite that range I get 1100 - 2000 on the throttle
 

ElectriSean

Eternal Student
Mentor
#12
Ok,

Step 1. Edit my channel throws to be 1000-2000. With Trims centered. Exactly? Or +- 5? Assuming in Betaflight, I can youtube that.
Step 2. Set my endpoint. What should be lower, the endpoint or the throw? How close? 5 or 25 or ? I think the throw.
Step 3. Recalibrate ESC's. In BLHELI or when binding like a Power Pack C?
Step 4. Finish moving my daughter from college before any other steps. Thanks guys for helping. Does it seem to you to be a simple setting?
If you can't get them centered at exactly 0 you can add some deadband to get rid of uncommanded movement.

Not sure what you mean by #2... There are 2 endpoints per channel. For example with yaw, full left stick should show 1000. Full right should show 2000. Or as close as you can get, it's not always perfect. Spektrum calls this adjustment servo travel, it should be in the servo menu on your transmitter.

Calibrate the ESC's from the motors tab in Betaflight. With the props off, set the master slider to full and plug in the battery. When the beeping stops, put the slider to zero. After the beeps disconnect the battery and you're good.
 

ElectriSean

Eternal Student
Mentor
#13

Frolic

"You are dead, Frolic"
#14
Hey hey!!!!!
I got the travels for all channels to go 1000-2000 +- 3
Flashed the arm to 1050
THEN Once I calibrated the ESC's I got it to arm AND the TX was able to run up all motors. BUT in checking them for directions one seemed to be having a much stronger spin. So I took a look under the motors tab and found this.
Capture.PNG

if the pic didn't load right it shows the second motor was 500 (insert unit here) above the others. So I recalibrated the ESC's one more time and still got the same issue. I am going to finish the build and put some props on to see if it flies. any thoughts?

Will post once I give it a whirl with props

Thanks guys for the help! You are awesome!
 

ElectriSean

Eternal Student
Mentor
#15
if the pic didn't load right it shows the second motor was 500 (insert unit here) above the others. So I recalibrated the ESC's one more time and still got the same issue. I am going to finish the build and put some props on to see if it flies. any thoughts?

Will post once I give it a whirl with props

Thanks guys for the help! You are awesome!
Glad you got it working :) What is probably happening with the one motor spooling up is that the FC is trying to correct the copters attitude, but with no props it has no effect. It keeps trying harder and harder and the motor ramps up. This is normal. Good luck with the maiden, let us know how it goes. Or even better, post a vid :)
 

Frolic

"You are dead, Frolic"
#17

So quick first flight, no big deal but THANKS SO MUCH KRAK and ElectriSean!!

Second flight vid to come shortly. But I now have some trouble. Arm, then fly, then it won't go to no throttle. Hot any thoughts?

I do have the throttle set from 1000-2000. Is that causing the lack of disarm? I did the first flights with batteries that were flown on the shipping charge. I think 4.8 per cell. But now trying the batteries charged.
Sorry the daughter didn't film landscape.
 

Frolic

"You are dead, Frolic"
#19
Right.

Gentle power up and it would get in the air. get over half throttle and it would fly ok. Lose control and put it down and the motors would keep spinning. at least 1/3 throttle. kinda scary disarm and the motors stop.

Double checking here.

Air mode = softest sticks most help, "auto level"
Horizon mode = medium I don't know what kind of help the fc is giving
Angle = least amount of help would this be "acro" people talk about?

So I can fly around in Air mode and If I crashed no big deal. But if I was in angle mode and crashed the motors would NOT stop spinning unless I disarmed.

Not sure why different flight modes would have different "settings" I have no numbers but it acts different.

How would i know if I am out of balance? The first time I looked through my goggles it was nice and crisp. I have crashed a few times, and now there is a bit of static when I throttle up and the quad changes sound, like a slight rattle.

Props all are intact but there is one blade with a little nick.
 

ElectriSean

Eternal Student
Mentor
#20
Air mode is not a flight mode in itself, what it does is keep the PID loop active at zero throttle so you still have control. It can be active in any of the flight modes. Angle mode is auto levelling, and will not allow you to exceed an angle even at full stick. Horizon is slightly less aggressive auto leveling and at full stick deflection will allow you to flip or roll. The lack of either horizon or angle is acro mode.

Most people have it set so that as soon as you arm it, the motors spin at min_throttle. If you want the motors to stop at zero throttle, enable MOTOR_STOP in the configuration tab. I personally prefer the motors to spin when armed, then there is no way I'm going to pick it up armed. There is also a feature in the configuration tab to disarm regardless of throttle value which I also recommend enabling.